Failed to find libraries with prefix 'libboost_' after pre-requisite installation

I am trying to install GNU Radio and UHD on a new PC with the latest
build-gnuradio script. (which includes gtk2-engines-pixbuf)

When the script checks the library after pre-requisite installation, an
error occurs and the script stops.
Here is the message when it occurs:

Checking for library libusb …Found library libusb
Checking for library libboost_ … build-gnuradio examples.desktop
tmp1883
Failed to find libraries with prefix ‘libboost_’ after pre-requisite
installation.
This very likely indicates that the pre-requisite installation failed to
install one or more critical pre-requisites for Gnu Radio/UHD
Show pre-requisites install log?y
prereq.log: No such file or directory
exiting build

I understood that libboost is not installed properly, and I tried:

sudo apt-get libboost-all-dev

which is a part of pre-requisites and re-run the script. But it failed
at
the same step.

So I’ve tried to modify the script:

Replace checklib libboost_ 5 with:

checklib libboost- 5 (replace the underbar with a hyphen, failed)
checklib libboost 5 (remove the underbar, failed)
checklib libboost_ 0 (change the number 5 to 0)

The last one has an effect, but I don’t think it solves problem clearly
Because changing that number to zero means skipping some procedure for
checking library
And this library checks also failed with the libraries which have the
number ‘5’, so I changed all of them

Anyway, currently I’m waiting for it to complete installation, and will
report after full installation

Anyone have idea for this, please give me a advice

Thanks

On 13/12/11 03:14 AM, Songsong G. wrote:

Failed to find libraries with prefix 'libboost_' after

    checklib libboost 5 (remove the underbar, failed)

What is your OS?

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs