Facing troubles installing rubymine latest one in vps ubuntu 12.04 64 bit

Hi all,

I have installed Redmine latest one in my vps. I am facing the below
error

apt-get install redmine redmine-mysql
Reading package lists… Done
Building dependency tree
Reading state information… Done
Suggested packages:
libsvn-ruby ruby-rmagick libopenid-ruby
The following NEW packages will be installed:
redmine redmine-mysql
0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/3,990 kB of archives.
After this operation, 10.8 MB of additional disk space will be used.
Preconfiguring packages …
Selecting previously unselected package redmine-mysql.
(Reading database … 98691 files and directories currently installed.)
Unpacking redmine-mysql (from
…/redmine-mysql_1.3.2+dfsg1-1ubuntu1_all.deb) …
Selecting previously unselected package redmine.
Unpacking redmine (from …/redmine_1.3.2+dfsg1-1ubuntu1_all.deb) …
Setting up redmine-mysql (1.3.2+dfsg1-1ubuntu1) …
Setting up redmine (1.3.2+dfsg1-1ubuntu1) …
dbconfig-common: writing config to
/etc/dbconfig-common/redmine/instances/default.conf

Creating config file /etc/dbconfig-common/redmine/instances/default.conf
with new version

Creating config file /etc/redmine/default/database.yml.new with new
version
granting access to database redmine_default for [email protected]:
success.
verifying access for [email protected]: success.
creating database redmine_default: success.
verifying database redmine_default exists: success.
dbconfig-common: flushing administrative password

Creating config file /etc/redmine/default/database.yml with new version
rake aborted!
undefined method `map’ for nil:NilClass
/usr/share/redmine/Rakefile:15
(See full trace by running task with --trace)
dpkg: error processing redmine (–configure):
subprocess installed post-installation script returned error exit
status 1
Errors were encountered while processing:
redmine
E: Sub-process /usr/bin/dpkg returned an error code (1)

the below is the Rakefile
require(File.join(File.dirname(FILE), ‘config’, ‘boot’))

require ‘rake’
require ‘rake/testtask’

begin
require ‘rdoc/task’
rescue LoadError

RDoc is not available

end

require ‘tasks/rails’ this is the 15th line.

Kindly let me know where is the issue.

Thanks in advance

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs