Facing dependency error for "faraday"

Hi,

Please solve below dependency.

Bundler could not find compatible versions for gem “faraday”:
In Gemfile:
swiftype (>= 0) ruby depends on
faraday (~> 0.8.1) ruby

context-io (>= 0) ruby depends on
  faraday (0.7.6)

I follow below links but not getting:-

http://stackoverflow.com/questions/6132479/2-gems-need-different-versions-of-the-same-dependencyhttp://stackoverflow.com/questions/8878980/rails-bundle-one-gem-two-versions?rq=1http://stackoverflow.com/questions/6320363/adding-2-versions-of-a-gem-in-bundler?rq=1

  1. 3:25 AM

ruby on rails 3 - Bundler could not find compatible versions for gem - Stack Overflow

Thanks

Best Regards
Fahim Babar Patel

On 18 June 2013 00:25, Fahim P. [email protected] wrote:

context-io (>= 0) ruby depends on
  faraday (0.7.6)

If what you have stated above is correct then you are stuck as there
is no version of faraday that will satisfy both requirements. Have
you checked whether you have the latest versions of context-io and
swiftype?

Try
bundle update swiftype
bundle update context-io
bundle install

Colin

Thanks Colin for reply.
When i try to fire your commands terminal get hanged.

Hi,

I caught up in the same situation when I was trying to use
pingdom-clienthttps://rubygems.org/gems/pingdom-clientand
google_drive http://rubygems.org/gems/google_drive together in one
application. Pingdom–client has dependency on faraday0.5.6 whereas
google_drive depends upon faraday0.8 . I downloaded the pingdom-client
gem,
stored it locally(not the standard ruby gems location) and in the
Gemfile
provided a local link. Then I changed in the config files the
dependency
to newer version of faraday. Though it didn’t work in my case for some
reason I don’t remember, you can try if this works for you. I’d love to
see
any standard solution to this.

Aman Mangal
3rd year Undergraduate
Department of Computer Science & Engineering
IIT Bombay
www.cse.iitb.ac.in/~amanmangal

Fahim P. [email protected] wrote:

Please solve below dependency.

Use contextio instead of context-io