Extconf of tcltklib for Aqua on MacOS X Tiger


#1

Hi,

I don’t know about development on MacOS X Tiger.
To make tcltklib for Aqua except X11, is the following patch to
‘ext/tcltklib/extconf.rb’ ( or ‘ext/tk/extconf.rb’) required?
Or is it nonsense?
If it is not nonsense and you can try it, please try it with
“–enable-macosx-aqua” configure option and teach me the result.

Index: extconf.rb

RCS file: /var/cvs/src/ruby/ext/tk/extconf.rb,v
retrieving revision 1.2.8.4
diff -u -r1.2.8.4 extconf.rb
— extconf.rb 2 Nov 2005 11:28:40 -0000 1.2.8.4
+++ extconf.rb 30 Nov 2005 05:45:16 -0000
@@ -32,6 +32,14 @@

tcltk_framework = find_framework(tcl_framework_header,
tk_framework_header)

+def use_macosx_aqua

  • if /darwin/ =~ RUBY_PLATFORM
  • enable_config(“macosx-aqua”, true)
  • else
  • false
  • end
    +end

unless is_win32
have_library(“nsl”, “t_open”)
have_library(“socket”, “socket”)
@@ -280,6 +288,11 @@
$CPPFLAGS += ’ -DUSE_TCL_STUBS -DUSE_TK_STUBS’ if stubs
$CPPFLAGS += ’ -D_WIN32’ if /cygwin/ =~ RUBY_PLATFORM

  • if use_macosx_aqua
  • $CPPFLAGS += ’ -DMAC_OSX_TK=1’
  • $LDFLAGS += ’ -framework CoreFoundation -framework Carbon’
  • end
  • if tcltk_framework
    if tcl_framework_header
    $CPPFLAGS += " -I#{tcl_framework_header}"

#2

From: Hidetoshi NAGAI removed_email_address@domain.invalid
Subject: extconf of tcltklib for Aqua on MacOS X Tiger
Date: Wed, 30 Nov 2005 15:01:47 +0900
Message-ID: removed_email_address@domain.invalid

If it is not nonsense and you can try it, please try it with
“–enable-macosx-aqua” configure option and teach me the result.

Preferably, please try on Ruby1.8.4-preview.
If it is valid, I want to adopt it for the next release of Ruby.


#3

From: Hidetoshi NAGAI removed_email_address@domain.invalid
Subject: Re: extconf of tcltklib for Aqua on MacOS X Tiger
Date: Wed, 30 Nov 2005 15:08:18 +0900
Message-ID: removed_email_address@domain.invalid

Preferably, please try on Ruby1.8.4-preview.
If it is valid, I want to adopt it for the next release of Ruby.

1.8.4-preview2 is available. So please try on 1.8.4-preview2.