Exerb and GUI's


#1

hi everyone :slight_smile:
i was wondering if i can pack applications with GUI’s using exerb, and
which
GUI’s, and how…
also, if there is any english documentation concerning this, could
someone
point me to it?
greetings, Dirk.


#2

On Tuesday 03 January 2006 17:00, Dirk M. wrote:

hi everyone :slight_smile:
i was wondering if i can pack applications with GUI’s using exerb, and
which GUI’s, and how…
also, if there is any english documentation concerning this, could someone
point me to it?
greetings, Dirk.

rubyscript2exe does packing of at least KDE ruby code just fine.


#3

Dirk M. wrote:

i was wondering if i can pack applications with GUI’s using exerb, and which
GUI’s, and how…
You can pack wxruby using Exerb. You’d use a line in your .exr recipe
like

add_extension_library wxruby.so C:/path/to/wxruby.so

As mentioned, you probably should look at rubyscript2exe for creating
ruby executables. It’s newer and superior to exerb in almost all
respects. It should work with most ruby GUIs (fox, wx, tk). Maybe
slightly more complicated for GUIs built with external dependencies
(GTK?), but still do-able.

alex


#4

On Tuesday 03 January 2006 18:03, Alex F. wrote:

should work with most ruby GUIs (fox, wx, tk). Maybe slightly more
complicated for GUIs built with external dependencies (GTK?), but still
do-able.

Uh, seems less complicated from what you’re saying about recipies? All
I do
to package my Korundum app is:

tar2rubyscript directoryname
rubyscript2exe directoryname.rb

And I have an executable called directoryname_linux. That’s it. The
only
thing you have to do to your code is have a file called init.rb that
actually
makes it go. It packages all the dependencies, etc.

So no, it’s not more complicated. :slight_smile:


#5

Maybe slightly more
complicated for GUIs built with external dependencies (GTK?), but still
do-able.

Uh, seems less complicated from what you’re saying about recipies?

Recipes are just for exerb. Annoying whatever GUI package you’re using.
One more good reason to use rs2exe.

I wasn’t trying to kick GTK. All I wanted to point out was that for GTK,
if you’re creating a package intended for distribution, your Windows
users will need the GTK+ runtime - either you must supply all the bits,
or they need to download and install it (as with GIMP).

Fxruby and wxruby are both standalone binaries on windows, so what
rubyscript2exe finds is all rubyscript2exe needs to run on any Windows
machine.

a