Execute cap deploy:migrations fails


#1

Hi there, I am trying to deploy a rails app on dreamhost.

Here is the error message that I get:

fatal: ‘home/USER_NAME/DOMAIN_NAME/git/APPLICATION_NAME.git’: unable
to chdir or not a git archive
fatal: The remote end hung up unexpectedly
/Users/USER/.gem/ruby/1.8/gems/capistrano-2.5.3/lib/capistrano/recipes/
deploy/scm/git.rb:224:in `query_revision’: Unable to resolve revision
for ‘master’ on repository

I am using Capistrano v2.5.3, Rails 2.2 and Git v1.6

I ran deploy:setup and deploy:check successfully. I get the following
message when I run deploy:check command “You appear to have all
necessary dependencies installed”.

Here is my deploy script

default_run_options[:pty] = true

be sure to change these

set :user, ‘USER_NAME’
set :domain, ‘DOMAIN_NAME’
set :application, ‘APP_NAME’

the rest should be good

set :repository, “#{user}@#{domain}:home/#{user}/#{domain}/git/#
{application}.git”
set :deploy_to, “/home/#{user}/#{domain}”
set :deploy_via, :remote_cache
set :scm, ‘git’
set :branch, ‘master’
set :git_shallow_clone, 1
set :scm_verbose, true
set :use_sudo, false

server domain, :app, :web
role :db, domain, :primary => true

namespace :deploy do
task :restart do
run “touch #{current_path}/tmp/restart.txt”
end
end

I am guessing my path to my git repository is incorrect but I checked
many … many times and this is my path on my host.

Any help would be greatly appreciated, thank you

Olivier


#2

Try to remove the “set :deploy_via, :remote_cache”, could never get it
to work.

Maurício Linhares
http://alinhavado.wordpress.com/ (pt-br) | http://blog.codevader.com/
(en)


#3

Looking at the print from capistrano:

fatal: ‘home/USER_NAME/DOMAIN_NAME/git/APPLICATION_NAME.git’:
unable ???

That just does not look right.

From the host where you have capistrano are you able to run git clone
and the git url ?

Here is a git example url

set :repository, “removed_email_address@domain.invalid:username/projectname.git”