Errors When Attempting "irb"

I am unable to use ruby’s interactive shell because of this ugly thing:

dyld: NSLinkModule() error
dyld: Symbol not found: _rl_filename_completion_function
Referenced from:
/usr/local/lib/ruby/1.8/i686-darwin9.2.2/readline.bundle
Expected in: flat namespace

Trace/BPT trap

anybody? It all started when I tried installing ruby 1.9 from source…

2008/3/27, Jacob L. [email protected]:

anybody? It all started when I tried installing ruby 1.9 from source…
And is your irb version 1.9 too?

anybody? It all started when I tried installing ruby 1.9 from source…

Have you removed 1.9 again?

Jacob L. wrote:

I am unable to use ruby’s interactive shell because of this ugly thing:

dyld: NSLinkModule() error
dyld: Symbol not found: _rl_filename_completion_function
Referenced from:
/usr/local/lib/ruby/1.8/i686-darwin9.2.2/readline.bundle
Expected in: flat namespace

Trace/BPT trap

anybody? It all started when I tried installing ruby 1.9 from source…

There’s a supposed issue with leopard… but I’m too much a noob to 1)
understand it fully and 2) follow directions to install a patch for it,
so I took this opportunity to do a fresh install of leopard. All
problems fixed and I’m sticking with ruby 1.8 for now.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs