Errors in production environment

Hi all.

I switched to production environment for my rails app.

My production environment is an apache2+mongrel.

All worked fine, but I have a problem: when an error is generated all
debug infos come out, as like as in development environment occurs.

What can be the problem?

Note that:

  • in my mongrel_cluster yml config file there is the line: environment:
    production
  • the app really runs in the production environment, because it reads
    data from production DB
  • I tried to set RAILS_ENV=production in environmet.rb, but it did not
    work
  • I also tried to set config.log_level = :info in environments.rb, but
    it did not work
  • inside the rails app the variable RAILS_ENV is set to production
  • if I launch ruby script/server -e production all works fine and I
    don’t see debug info on errors

The strange thing is that it really runs in production environment but
the error pages have debug info. Besides this does not occur if I launch
mongrel_rails from command line but only with mongrel clusters

Thanks to all

The basics first I suppose. Did you restart your mongrels after
updating
the environment.rb? Also, are you sure the log level is malfunctioning?
Maybe you want to set it to another level like :error or :fatal. Maybe
try
one of those out first and see if it’s closer to what you are looking
for.

Raul

----- Original Message -----
From: “Sam P.” [email protected]
To: [email protected]
Sent: Tuesday, May 06, 2008 11:45 AM
Subject: [Rails-deploy] Errors in production environment

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs