Errors after updating please help!


#1

Hello!

I recently upgraded to rails 1.1.6.

When i fired up my application, it started up okay except i get this
warning:

…/config/boot.rb 28: Warning require_gem is obsolete. Use gem instead

How do I fix this?

And when i actually try to access something in my database I get this
error:

wrong number of arguments (1 for 0)

I have no idea what the problem is here. I can give u the complete
trace here:

C:/Documents and Settings/Tyler/My Documents/ruby/lib/ruby/gems/1.8/
gems/activerecord-1.14.4/lib/active_record/vendor/mysql.rb:551:in
initialize' C:/Documents and Settings/Tyler/My Documents/ruby/lib/ruby/gems/1.8/ gems/activerecord-1.14.4/lib/active_record/vendor/mysql.rb:551:innew’
C:/Documents and Settings/Tyler/My Documents/ruby/lib/ruby/gems/1.8/
gems/activerecord-1.14.4/lib/active_record/vendor/mysql.rb:551:in
scramble41' C:/Documents and Settings/Tyler/My Documents/ruby/lib/ruby/gems/1.8/ gems/activerecord-1.14.4/lib/active_record/vendor/mysql.rb:141:inreal_connect’
C:/Documents and Settings/Tyler/My Documents/ruby/lib/ruby/gems/1.8/
gems/activerecord-1.14.4/lib/active_record/connection_adapters/
mysql_adapter.rb:330:in connect' C:/Documents and Settings/Tyler/My Documents/ruby/lib/ruby/gems/1.8/ gems/activerecord-1.14.4/lib/active_record/connection_adapters/ mysql_adapter.rb:87:ininitialize’
C:/Documents and Settings/Tyler/My Documents/ruby/lib/ruby/gems/1.8/
gems/activerecord-1.14.4/lib/active_record/connection_adapters/
mysql_adapter.rb:36:in new' C:/Documents and Settings/Tyler/My Documents/ruby/lib/ruby/gems/1.8/ gems/activerecord-1.14.4/lib/active_record/connection_adapters/ mysql_adapter.rb:36:inmysql_connection’
C:/Documents and Settings/Tyler/My Documents/ruby/lib/ruby/gems/1.8/
gems/activerecord-1.14.4/lib/active_record/connection_adapters/
abstract/connection_specification.rb:251:in send' C:/Documents and Settings/Tyler/My Documents/ruby/lib/ruby/gems/1.8/ gems/activerecord-1.14.4/lib/active_record/connection_adapters/ abstract/connection_specification.rb:251:inconnection_without_query_cache=’
C:/Documents and Settings/Tyler/My Documents/ruby/lib/ruby/gems/1.8/
gems/activerecord-1.14.4/lib/active_record/query_cache.rb:54:in
connection=' C:/Documents and Settings/Tyler/My Documents/ruby/lib/ruby/gems/1.8/ gems/activerecord-1.14.4/lib/active_record/connection_adapters/ abstract/connection_specification.rb:220:inretrieve_connection’
C:/Documents and Settings/Tyler/My Documents/ruby/lib/ruby/gems/1.8/
gems/activerecord-1.14.4/lib/active_record/connection_adapters/
abstract/connection_specification.rb:78:in connection' C:/Documents and Settings/Tyler/My Documents/ruby/lib/ruby/gems/1.8/ gems/activerecord-1.14.4/lib/active_record/base.rb:696:incolumns’
C:/Documents and Settings/Tyler/My Documents/ruby/lib/ruby/gems/1.8/
gems/activerecord-1.14.4/lib/active_record/base.rb:1969:in
attributes_from_column_definition' C:/Documents and Settings/Tyler/My Documents/ruby/lib/ruby/gems/1.8/ gems/activerecord-1.14.4/lib/active_record/base.rb:1351:ininitialize_without_callbacks’
C:/Documents and Settings/Tyler/My Documents/ruby/lib/ruby/gems/1.8/
gems/activerecord-1.14.4/lib/active_record/callbacks.rb:236:in
initialize' #{RAILS_ROOT}/app/controllers/homepage_controller.rb:102:innew’
#{RAILS_ROOT}/app/controllers/homepage_controller.rb:102:in new' C:/Documents and Settings/Tyler/My Documents/ruby/lib/ruby/gems/1.8/ gems/actionpack-1.12.5/lib/action_controller/base.rb:941:insend’
C:/Documents and Settings/Tyler/My Documents/ruby/lib/ruby/gems/1.8/
gems/actionpack-1.12.5/lib/action_controller/base.rb:941:in
perform_action_without_filters' C:/Documents and Settings/Tyler/My Documents/ruby/lib/ruby/gems/1.8/ gems/actionpack-1.12.5/lib/action_controller/filters.rb:368:inperform_action_without_benchmark’
C:/Documents and Settings/Tyler/My Documents/ruby/lib/ruby/gems/1.8/
gems/actionpack-1.12.5/lib/action_controller/benchmarking.rb:69:in
perform_action_without_rescue' C:/Documents and Settings/Tyler/My Documents/ruby/lib/ruby/1.8/ benchmark.rb:293:inmeasure’
C:/Documents and Settings/Tyler/My Documents/ruby/lib/ruby/gems/1.8/
gems/actionpack-1.12.5/lib/action_controller/benchmarking.rb:69:in
perform_action_without_rescue' C:/Documents and Settings/Tyler/My Documents/ruby/lib/ruby/gems/1.8/ gems/actionpack-1.12.5/lib/action_controller/rescue.rb:82:inperform_action’
C:/Documents and Settings/Tyler/My Documents/ruby/lib/ruby/gems/1.8/
gems/actionpack-1.12.5/lib/action_controller/base.rb:408:in send' C:/Documents and Settings/Tyler/My Documents/ruby/lib/ruby/gems/1.8/ gems/actionpack-1.12.5/lib/action_controller/base.rb:408:inprocess_without_filters’
C:/Documents and Settings/Tyler/My Documents/ruby/lib/ruby/gems/1.8/
gems/actionpack-1.12.5/lib/action_controller/filters.rb:377:in
process_without_session_management_support' C:/Documents and Settings/Tyler/My Documents/ruby/lib/ruby/gems/1.8/ gems/actionpack-1.12.5/lib/action_controller/session_management.rb: 117:inprocess’
C:/Documents and Settings/Tyler/My Documents/ruby/lib/ruby/gems/1.8/
gems/rails-1.1.6/lib/dispatcher.rb:38:in dispatch' C:/Documents and Settings/Tyler/My Documents/ruby/lib/ruby/gems/1.8/ gems/rails-1.1.6/lib/webrick_server.rb:115:inhandle_dispatch’
C:/Documents and Settings/Tyler/My Documents/ruby/lib/ruby/gems/1.8/
gems/rails-1.1.6/lib/webrick_server.rb:81:in service' C:/Documents and Settings/Tyler/My Documents/ruby/lib/ruby/1.8/webrick/ httpserver.rb:104:inservice’
C:/Documents and Settings/Tyler/My Documents/ruby/lib/ruby/1.8/webrick/
httpserver.rb:65:in run' C:/Documents and Settings/Tyler/My Documents/ruby/lib/ruby/1.8/webrick/ server.rb:173:instart_thread’
C:/Documents and Settings/Tyler/My Documents/ruby/lib/ruby/1.8/webrick/
server.rb:162:in start' C:/Documents and Settings/Tyler/My Documents/ruby/lib/ruby/1.8/webrick/ server.rb:162:instart_thread’
C:/Documents and Settings/Tyler/My Documents/ruby/lib/ruby/1.8/webrick/
server.rb:95:in start' C:/Documents and Settings/Tyler/My Documents/ruby/lib/ruby/1.8/webrick/ server.rb:92:ineach’
C:/Documents and Settings/Tyler/My Documents/ruby/lib/ruby/1.8/webrick/
server.rb:92:in start' C:/Documents and Settings/Tyler/My Documents/ruby/lib/ruby/1.8/webrick/ server.rb:23:instart’
C:/Documents and Settings/Tyler/My Documents/ruby/lib/ruby/1.8/webrick/
server.rb:82:in start' C:/Documents and Settings/Tyler/My Documents/ruby/lib/ruby/gems/1.8/ gems/rails-1.1.6/lib/webrick_server.rb:67:indispatch’
C:/Documents and Settings/Tyler/My Documents/ruby/lib/ruby/gems/1.8/
gems/rails-1.1.6/lib/commands/servers/webrick.rb:59
C:/Documents and Settings/Tyler/My Documents/ruby/lib/ruby/site_ruby/
1.8/rubygems/custom_require.rb:27:in gem_original_require' C:/Documents and Settings/Tyler/My Documents/ruby/lib/ruby/site_ruby/ 1.8/rubygems/custom_require.rb:27:inrequire’
C:/Documents and Settings/Tyler/My Documents/ruby/lib/ruby/gems/1.8/
gems/activesupport-1.3.1/lib/active_support/dependencies.rb:147:in
require' C:/Documents and Settings/Tyler/My Documents/ruby/lib/ruby/gems/1.8/ gems/rails-1.1.6/lib/commands/server.rb:30 C:/Documents and Settings/Tyler/My Documents/ruby/lib/ruby/site_ruby/ 1.8/rubygems/custom_require.rb:27:ingem_original_require’
C:/Documents and Settings/Tyler/My Documents/ruby/lib/ruby/site_ruby/
1.8/rubygems/custom_require.rb:27:in require' C:/Documents and Settings/Tyler/My Documents/ruby/lib/ruby/gems/1.8/ gems/activesupport-1.3.1/lib/active_support/dependencies.rb:147:inrequire’
script/server:3


#2

I found a website that solved the DB problem.

http://hillemania.wordpress.com/2006/09/21/rails-mysql-50-on-windows-setup-problemfix-libmysqldll/