Error with WEBrick server

hii i decided to move from windows to linux (ubuntu 9.10) so i
installed ruby 1.8 rails 2.3.5 and sqlite 3
but when i lunch my WEBrick server it give me this error :

=>Booting WEBrick
=> Rails 2.3.5 application starting on http://0.0.0.0:3000
/usr/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:271:in
require_frameworks': no such file to load -- net/https (RuntimeError) from /usr/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb: 134:inprocess’
from /usr/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:
113:in send' from /usr/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb: 113:inrun’
from /home/spyshow/Documents/rails_project/simple_app/config/
environment.rb:9
from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in
gem_original_require' from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:inrequire’
from /usr/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/
active_support/dependencies.rb:156:in require' from /usr/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/ active_support/dependencies.rb:521:innew_constants_in’
from /usr/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/
active_support/dependencies.rb:156:in require' from /usr/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/commands/server.rb: 84 from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:ingem_original_require’
from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in
`require’
from script/server:3

On Jan 19, 5:05Â pm, Jihad K. [email protected] wrote:

so any idea what is going wrong ??
and how i can use (install) another server other than WEbrick ??

It’s nothing to do with webrick - Active Resource is trying to load
net/https which apparently you don’t have (linux distros often split
ruby into several bits). You could either install the missing bits of
ruby or disable Active Resource

Fred

Search on the Ubuntu wiki for Rails install help. It’s a process, but
if you follow it and do it right, you get a much better install, at
least for beginners.

Synopsis:

Install ruby using atp-get
Install gems (from urls given in the guide)
Install everything else from gems

On Tue, Jan 19, 2010 at 9:39 AM, Frederick C.
[email protected] wrote:


You received this message because you are subscribed to the Google G. “Ruby on Rails: Talk” group.
To post to this group, send email to [email protected]
To unsubscribe from this group, send email to [email protected]
For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.


Curtis C.
[email protected]
home:http://curtiscooley.com
blog:http://ponderingobjectorienteddesign.blogspot.com

Leadership is a potent combination of strategy and character. But if
you must be without one, be without the strategy.
– H. Norman Schwarzkopf

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs