Error with ruby

Could not find gem ‘typhoeus (~> 0.6.8) x64-mingw32’ in the gems
available on this machine.
Run bundle install to install missing gems.

And when i tried “bundle install”

i got this

DL is deprecated, please use Fiddle
Don’t run Bundler as root. Bundler can ask for sudo if it is needed, and
installing your bundle as root will break this application for all
non-root
users on this machine.
Fetching gem metadata from https://rubygems.org/
Fetching additional metadata from https://rubygems.org/
Resolving dependencies…
Using addressable 2.3.6
Using safe_yaml 1.0.3
Using crack 0.4.2
Using diff-lcs 1.2.5
Using docile 1.1.3
Using ffi 1.9.3
Using ethon 0.7.0

Gem::InstallError: The ‘json’ native gem requires installed build tools.

Please update your PATH to include build tools or download the DevKit
from ‘http://rubyinstaller.org/downloads’ and follow the instructions
at ‘http://github.com/oneclick/rubyinstaller/wiki/Development-Kit
An error occurred while installing json (1.8.1), and Bundler cannot
continue.
Make sure that gem install json -v '1.8.1' succeeds before bundling.

i am using ruby on windows 7 64bit
plz help me

It looks like the gem you want to install uses the json gem, and when
bundler tried to install the json gem, it couldn’t. Did you
subsequently try doing this:

download the DevKit
from ‘http://rubyinstaller.org/downloads’ and follow the instructions
at 'http://github.com/oneclick/rubyinstaller/wiki/Deve

Note: remove the erroneous trailing quote in the first link to get to
the right page.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs