Error with 'require'


#1

Hi!

I’m new to Ruby.

I try to make a “require 'nokogiri”, but get this error:

nationalBanken.rb:1:in `require’: no such file to load – nokogiri
(LoadError)
from nationalBanken.rb:1

I have tried to install nokogiri both from gems and from a Fedora 10
package: rubygem-nokogiri.
I get the same error when I tried with hpricot.

Anyone who can help?


#2

Kris Thomsen wrote:

nationalBanken.rb:1:in `require’: no such file to load – nokogiri
(LoadError)
from nationalBanken.rb:1

require ‘rubygems’ first.


#3

Phlip wrote:

Kris Thomsen wrote:

nationalBanken.rb:1:in `require’: no such file to load – nokogiri
(LoadError)
from nationalBanken.rb:1

require ‘rubygems’ first.

Thanks!
That worked perfect :slight_smile: