Error while uploading images using attachment_fu on windows

I am a newbie to Rails and i am trying the attachment_fu plugin. I am
referring to the post from the url
http://clarkware.com/cgi/blosxom/2007/02/24

When i try to upload an image i am getting the below error. I am using
RMagick. Instead of max_size, i am using size for the attachment
options in the model.

undefined method `include?’ for 512000:Fixnum

vendor/plugins/attachment_fu/lib/technoweenie/attachment_fu.rb:381:in
attachment_attributes_valid?' vendor/plugins/attachment_fu/lib/technoweenie/attachment_fu.rb:379:ineach’
vendor/plugins/attachment_fu/lib/technoweenie/attachment_fu.rb:379:in
attachment_attributes_valid?' c:/ruby/lib/ruby/gems/1.8/gems/activerecord-2.0.2/lib/active_record/ validations.rb:1000:insend’
c:/ruby/lib/ruby/gems/1.8/gems/activerecord-2.0.2/lib/active_record/
validations.rb:1000:in run_validations' c:/ruby/lib/ruby/gems/1.8/gems/activerecord-2.0.2/lib/active_record/ validations.rb:998:ineach’
c:/ruby/lib/ruby/gems/1.8/gems/activerecord-2.0.2/lib/active_record/
validations.rb:998:in run_validations' c:/ruby/lib/ruby/gems/1.8/gems/activerecord-2.0.2/lib/active_record/ validations.rb:962:invalid_without_callbacks?’
c:/ruby/lib/ruby/gems/1.8/gems/activerecord-2.0.2/lib/active_record/
callbacks.rb:273:in valid?' c:/ruby/lib/ruby/gems/1.8/gems/activerecord-2.0.2/lib/active_record/ validations.rb:933:insave_without_transactions’
c:/ruby/lib/ruby/gems/1.8/gems/activerecord-2.0.2/lib/active_record/
transactions.rb:108:in save' c:/ruby/lib/ruby/gems/1.8/gems/activerecord-2.0.2/lib/active_record/ connection_adapters/abstract/database_statements.rb:66:intransaction’
c:/ruby/lib/ruby/gems/1.8/gems/activerecord-2.0.2/lib/active_record/
transactions.rb:80:in transaction' c:/ruby/lib/ruby/gems/1.8/gems/activerecord-2.0.2/lib/active_record/ transactions.rb:100:intransaction’
c:/ruby/lib/ruby/gems/1.8/gems/activerecord-2.0.2/lib/active_record/
transactions.rb:108:in save' c:/ruby/lib/ruby/gems/1.8/gems/activerecord-2.0.2/lib/active_record/ transactions.rb:120:inrollback_active_record_state!’
c:/ruby/lib/ruby/gems/1.8/gems/activerecord-2.0.2/lib/active_record/
transactions.rb:108:in `save’

Can someone help in resolving this issue.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs