Error while trying to install rails on JRuby

Hi,
I am new to JRuby and trying to install the rails on JRuby and getting
the
below error.
“The filename, directory name, or volume label syntax is incorrect.”

For your convenience, I printed the environment variables.
_STARTJAVA
JRUBY_BAT_ERROR
_VM_OPTS
CLASSPATH
C:\Softwares\jruby-1.1.1\lib\bsf.jar;C:\Softwares\jruby-1.1.1\lib\prof
ile.jar;C:\Softwares\jruby-1.1.1\lib\jruby.jar
JRUBY_HOME C:\Softwares\jruby-1.1.1
JRUBY_OPTS
ERRORLEVEL 0
The filename, directory name, or volume label syntax is incorrect.

I am not sure why I am getting this error. I checked the Proxy setting
and
disabled it. Still I am getting the same error. I would appreciate if
someone can help me in resolving this.

Thanks

View this message in context:
http://www.nabble.com/Error-while-trying-to-install-rails-on-JRuby-tp17042885p17042885.html
Sent from the JRuby - User mailing list archive at Nabble.com.


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

What syntax were you using? And the jruby/bin directory should be in
your PATH.

Give the following a shot:

jruby -S gem install rails

On Sun, May 4, 2008 at 1:11 AM, rgmoganti [email protected] wrote:

CLASSPATH


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

I added JRuby/bin to PATH variable and tried the below command (jruby -S
gem
install rails). But still I am getting the same error.
“C:\Softwares\jruby-1.1.1\bin>jruby -S gem install rails
The filename, directory name, or volume label syntax is incorrect.”
Here is the JRuby version I installed “jruby-1.1.1” and the PATH
variable
“C:\Documents and Settings\gangs>echo %PATH%
c:\Softwares\Perl\bin;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:
\Program Files\Common Files\Ulead Systems\MPEG;C:\Program Files\Ulead
Systems\Ul
ead VideoStudio 8.0 SE DVD\DMF;C:\Program Files\Common Files\Roxio
Shared\DLLSha
red;C:\Softwares\jruby-1.1.1\bin;”

I appreciate any help in this regard.

Thanks

MDWeezer wrote:

Hi,
C:\Softwares\jruby-1.1.1\lib\bsf.jar;C:\Softwares\jruby-1.1.1\lib\prof

http://xircles.codehaus.org/manage_email


View this message in context:
http://www.nabble.com/Error-while-trying-to-install-rails-on-JRuby-tp17042885p17160036.html
Sent from the JRuby - User mailing list archive at Nabble.com.


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

rgmoganti wrote:

Hi,
I am new to JRuby and trying to install the rails on JRuby and getting
the
below error.
“The filename, directory name, or volume label syntax is incorrect.”

I’m getting this error, but while using any “gem” command, and on a
Windows box.

Turns out that RubyGems installs C:\Program Files\Ruby\bin\gem.bat,
WHICH CONTAINS TWO SYNTAX ERRORS:

@ECHO OFF
IF NOT “%~f0” == “~f0” GOTO :WinNT
@“ruby.exe”" “c:/program files/ruby/bin/gem” %1 %2 %3 %4 %5 %6 %7 %8 %9
GOTO :EOF
:WinNT
@“ruby.exe”" “%~dpn0” %*

Notice the double double-quotes after ruby.exe? Remove one of those
double-quotes, and the error will go away.

I have a feeling there’s a related error in your JRuby install.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

rgmoganti wrote:
| I added JRuby/bin to PATH variable and tried the below command (jruby

  • -S gem
    | install rails). But still I am getting the same error.
    | “C:\Softwares\jruby-1.1.1\bin>jruby -S gem install rails
    | The filename, directory name, or volume label syntax is incorrect.”
    | Here is the JRuby version I installed “jruby-1.1.1” and the PATH variable
    | “C:\Documents and Settings\gangs>echo %PATH%
    |
    c:\Softwares\Perl\bin;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:
    | \Program Files\Common Files\Ulead Systems\MPEG;C:\Program Files\Ulead
    | Systems\Ul
    | ead VideoStudio 8.0 SE DVD\DMF;C:\Program Files\Common Files\Roxio
    | Shared\DLLSha
    | red;C:\Softwares\jruby-1.1.1\bin;”
    |
    | I appreciate any help in this regard.

It doesn’t look like a path issue.

If it were, it should look like this:

C:\Documents and Settings\CynicalRyan>noexec
‘noexec’ is not recognized as an internal or external command,
operable program or batch file.

Run scandisk/chkdsk on your system (depending on your Windows version,
for NT-based it’s the latter, for Win95-based it’s the former), to rule
out issues with your file system.

You might also check for this:
http://www.microsoft.com/technet/prodtechnol/windows2000serv/reskit/w2000Msgs/2993.mspx?mfr=true

Even though, try a reboot. Windows versions before Vista need a reboot
or log off/log on cycle so that the path propagates properly into the
cmd shell.


Phillip G.
Twitter: twitter.com/cynicalryan
Blog: http://justarubyist.blogspot.com

Terminate input by end-of-file or marker, not by count.
~ - The Elements of Programming Style (Kernighan & Plaugher)
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.8 (MingW32)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iEYEARECAAYFAkglOeEACgkQbtAgaoJTgL8szACfZbNoUcLYaGTsTgaS1DqjFOZU
zqMAoKOi5IO9q+5GAo3zOBdyVtcZC0wV
=BlAA
-----END PGP SIGNATURE-----


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs