Error while running ruby script/server

I ran the same command in my other project and the server started
without any errors but when I created a new project, I am getting the
following error. I would appreciate any pointers.

Thanks

Syed

D:\AddressBook>ruby script/server
=> Booting WEBrick…
D:/ruby/lib/ruby/1.8/yaml.rb:133:in load': syntax error on line 18, col 2: host: localhost’ (ArgumentError)
from D:/ruby/lib/ruby/1.8/yaml.rb:133:in load' from D:/ruby/lib/ruby/gems/1.8/gems/rails-1.2.6/lib/initializer.rb:551:indatabase_configuration’
from
D:/ruby/lib/ruby/gems/1.8/gems/rails-1.2.6/lib/initializer.rb:234:in
initialize_database' from D:/ruby/lib/ruby/gems/1.8/gems/rails-1.2.6/lib/initializer.rb:92:inprocess’
from
D:/ruby/lib/ruby/gems/1.8/gems/rails-1.2.6/lib/initializer.rb:47:in
send' from D:/ruby/lib/ruby/gems/1.8/gems/rails-1.2.6/lib/initializer.rb:47:inrun’
from ./script/…/config/…/config/environment.rb:13
from D:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
gem_original_require'... 10 levels... from D:/ruby/lib/ruby/gems/1.8/gems/rails-1.2.6/lib/commands/server.rb:39 from D:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:ingem_original_require’
from D:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`require’
from script/server:3

Show us your database.yml please.

On Dec 5, 2007 1:50 PM, Syed R. [email protected]
wrote:

=> Booting WEBrick…
D:/ruby/lib/ruby/gems/1.8/gems/rails-1.2.6/lib/initializer.rb:92:in
from


Ryan B.

Did you use a tab instead of spaces? YAML doesn’t like tabs.

-Bill

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs