Error while building 3.7.3 on RHEL6

Hi all guys,

I have again prob;lem building new version of gnuradio on my RHEL6
machine.
The error is following:

[ 26%] Building CXX object
gr-blocks/lib/CMakeFiles/gnuradio-blocks.dir/message_strobe_random_impl.cc.o
In file included from
/home/savi_ne/tools/gnuradio-3.7.3/gr-blocks/lib/message_strobe_random_impl.cc:27:
/home/savi_ne/tools/gnuradio-3.7.3/gr-blocks/lib/message_strobe_random_impl.h:48:
error: ‘mt19937’ in namespace ‘boost::random’ does not name a type
/home/savi_ne/tools/gnuradio-3.7.3/gr-blocks/lib/message_strobe_random_impl.cc:
In constructor
‘gr::blocks::message_strobe_random_impl::message_strobe_random_impl(pmt::pmt_t,
gr::blocks::message_strobe_random_distribution_t, float, float)’:
/home/savi_ne/tools/gnuradio-3.7.3/gr-blocks/lib/message_strobe_random_impl.cc:57:
error: class ‘gr::blocks::message_strobe_random_impl’ does not have any
field named ‘d_rng’
/home/savi_ne/tools/gnuradio-3.7.3/gr-blocks/lib/message_strobe_random_impl.cc:
In member function ‘void
gr::blocks::message_strobe_random_impl::update_dist()’:
/home/savi_ne/tools/gnuradio-3.7.3/gr-blocks/lib/message_strobe_random_impl.cc:89:
error: ‘d_rng’ was not declared in this scope
make[2]: ***
[gr-blocks/lib/CMakeFiles/gnuradio-blocks.dir/message_strobe_random_impl.cc.o]
Error 1
make[1]: *** [gr-blocks/lib/CMakeFiles/gnuradio-blocks.dir/all] Error 2

Has anybody had this error before?

Best,

Hi Nemanja,

that issue has been fixed in more recent GR versions (it was a
incompatibility with old Boost versions).
If you do not wish to update GNU Radio, just replace
boost::random::mt19937 by boost::mt19937 in message_strobe_random_impl.

Greetings,
Marcus

PS: Googling for “error: mt19937 in namespace boost::random does not
name a type” turns up my previous posts about the issue. This is really
just a friendly reminder that you should make sure that your questions
have not yet been answered before posting to the list, since this is
more often than not even faster than asking :slight_smile:

You are right regarding search, I have no excuse, and thanks for helping
me.

Unfortunatelly there is another error which is not reported by anybody
since now:

[ 74%] Building CXX object
gr-qtgui/lib/CMakeFiles/gnuradio-qtgui.dir/qtgui_util.cc.o
/home/savi_ne/tools/gnuradio-3.7.3/gr-qtgui/lib/qtgui_util.cc: In
function
‘QString get_qt_style_sheet(QString)’:
/home/savi_ne/tools/gnuradio-3.7.3/gr-qtgui/lib/qtgui_util.cc:30: error:
‘QFile’ was not declared in this scope
/home/savi_ne/tools/gnuradio-3.7.3/gr-qtgui/lib/qtgui_util.cc:30: error:
expected ‘;’ before ‘ss’
/home/savi_ne/tools/gnuradio-3.7.3/gr-qtgui/lib/qtgui_util.cc:31: error:
‘ss’ was not declared in this scope
/home/savi_ne/tools/gnuradio-3.7.3/gr-qtgui/lib/qtgui_util.cc:35: error:
‘ss’ was not declared in this scope
make[2]: ***
[gr-qtgui/lib/CMakeFiles/gnuradio-qtgui.dir/qtgui_util.cc.o]
Error 1
make[1]: *** [gr-qtgui/lib/CMakeFiles/gnuradio-qtgui.dir/all] Error 2
make: *** [all] Error 2

Since I use only WXGui I tried to turn off QtGUI in the configuration by
running ccmake and setting the flag to off, but then some other problems
appear rgarding doxigen:

Scanning dependencies of target digital_generated_includes
[ 6%] Generating chunks_to_symbols_bf.h, chunks_to_symbols_bc.h,
chunks_to_symbols_sf.h, chunks_to_symbols_sc.h, chunks_to_symbols_if.h,
chunks_to_symbols_ic.h
[ 6%] Built target digital_generated_includes
Scanning dependencies of target doxygen_target
make[2]: *** No rule to make target trellis_generated_includes', needed bydocs/doxygen/xml’. Stop.
make[1]: *** [docs/doxygen/CMakeFiles/doxygen_target.dir/all] Error 2
make: *** [all] Error 2

Hw can I now overcome this?

Thanx,
Nemanja

I am trying to build 3.7.3, and doxygen version is:
doxygen-1.6.1-6.el6.x86_64.
I tried to run again and got the error again.

On Fri, May 9, 2014 at 9:14 AM, Nemanja S. [email protected]
wrote:

I am trying to build 3.7.3, and doxygen version is:
doxygen-1.6.1-6.el6.x86_64.
I tried to run again and got the error again.

try: “cd gr-trellis; make” and let that complete. Then try again.

Tom

On Fri, May 9, 2014 at 8:01 AM, Nemanja S. [email protected]
wrote:

expected ‘;’ before ‘ss’
running ccmake and setting the flag to off, but then some other problems
make[1]: *** [docs/doxygen/CMakeFiles/doxygen_target.dir/all] Error 2
make: *** [all] Error 2

Hw can I now overcome this?

Thanx,
Nemanja

Just try running ‘make’ again. What version are you using? That doxygen
bug
should have been fixed already.

Tom

make in gr-trellis folder works, but when I run again from build folder
the
same error appears.

On Fri, May 9, 2014 at 9:29 AM, Nemanja S. [email protected]
wrote:

make in gr-trellis folder works, but when I run again from build folder
the same error appears.

Ok, well this is getting boring. For things like this, best to jump into
our IRC chatroom to work through it. No one wants to see us go back in
forth on “try this and that.” Any followup should be a resolution.

Tom

Ok, I’ll try there. Do you have any idea what is the problem with QFile
while building qtgui.

It look like RHEL6 use really old library:
qt3-3.3.8b-30.el6.x86_64

On Fri, May 9, 2014 at 9:43 AM, Nemanja S. [email protected]
wrote:

Ok, I’ll try there. Do you have any idea what is the problem with QFile
while building qtgui.

That one seems strange, being such an integral part of QT. But my guess
is
that it’s an API change in a QT version that we missed. (We’ll be
updating
the QT minimum version in 3.8).

When asking questions related to a dependency like this, it’s always
best
to give us the the version of the library.

Tom

I finally disabled doxygen and everything was built fine, but the test
fails at pfb_arb_resampler:

FAIL: test_ccf_001 (main.test_pfb_arb_resampler)

Traceback (most recent call last):
File
“/home/savi_ne/tools/gnuradio-3.7.3/gr-filter/python/filter/qa_pfb_arb_resampler.py”,
line 153, in test_ccf_001
self.assertComplexTuplesAlmostEqual(expected_data[-Ntest:],
dst_data[-Ntest:], 2)
File
“/home/savi_ne/tools/gnuradio-3.7.3/gnuradio-runtime/python/gnuradio/gr_unittest.py”,
line 74, in assertComplexTuplesAlmostEqual
self.assertComplexAlmostEqual (a[i], b[i], places, msg)
File
“/home/savi_ne/tools/gnuradio-3.7.3/gnuradio-runtime/python/gnuradio/gr_unittest.py”,
line 47, in assertComplexAlmostEqual
(msg or ‘%s != %s within %s places’ % (first, second, places
))
AssertionError: (-0.32564974754236342-0.94549047690899302j) !=
(-0.56183856725692749-0.82724255323410034j) within 2 places

Did anybody has the same problem?

Best,
Nemanja

On Fri, May 9, 2014 at 10:00 AM, Nemanja S. [email protected]
wrote:

It look like RHEL6 use really old library:
qt3-3.3.8b-30.el6.x86_64

Well that doesn’t make any sense. gr-qtgui looks for QT 4.2 or higher.
It
should not have even been enabled without finding QT4 on your system.
Are
you sure that’s the only version of QT you have installed?

And yes, Redhat is years behind. I suggest using pybombs (
gnuradio.org/pybombs), which was build for such purposes.

Tom

On 12.05.2014 12:53, Nemanja S. wrote:

dst_data[-Ntest:], 2)
File

“/home/savi_ne/tools/gnuradio-3.7.3/gnuradio-runtime/python/gnuradio/gr_unittest.py”,

line 74, in assertComplexTuplesAlmostEqual
self.assertComplexAlmostEqual (a[i], b[i], places, msg)
File

“/home/savi_ne/tools/gnuradio-3.7.3/gnuradio-runtime/python/gnuradio/gr_unittest.py”,

line 47, in assertComplexAlmostEqual
(msg or ‘%s != %s within %s places’ % (first, second, places ))
AssertionError: (-0.32564974754236342-0.94549047690899302j) !=
(-0.56183856725692749-0.82724255323410034j) within 2 places

Which VOLK machine are you using?

Martin

It is written:
Using Volk machine: avx_64_mmx

Best

So, is there any solution or nobody did see the last email?

Best,
Nemanja

On Fri, May 23, 2014 at 6:14 AM, Nemanja S. [email protected]
wrote:

So, is there any solution or nobody did see the last email?

Best,
Nemanja

It’s hard to track the issue through so many emails that switch topics.
Can
you start a new thread with all of the relevant information. When
dealing
with numerical errors, please remember to include information about the
processor and platform you’re running on.

Tom

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs