Error when trying to create new app

Hi, First let me say that I’m a total newbie and I just installed ruby
on
rails :smiley:

After installing rails on my computer I am getting the following error
when
I try to create a new app. In the command prompt I type in “rails new
nameofapp” and it installs some things and then spits out the following
error message, “An error occurred while installing rake <10.4.2>, and
Bundler cannot continue. Make sure that 'gem install rake -v ‘10.4.2’
succeeds before bundling.”

What is this error message and what do I do?

I’m using Windows 8 and Rails Installer 1.9.

thanks,
josh

I don’t have much experience in rails to tell you what to do, but open
your command promt and run this:

$ gem install rake -v 10.4.2

This message is telling you that the rails can’t install this gem, and
you need this. Send me some message when you thy this, because I don’t
have sure that this will work.

It said, “’$’ is not recognized as an internal or external command,
operable program or batch file.”

On Wednesday, February 25, 2015 at 5:53:59 PM UTC-6, Ruby-Forum.com User

On 25 February 2015 at 23:08, Josh L. [email protected]
wrote:

What is this error message and what do I do?

I’m using Windows 8 and Rails Installer 1.9.

I suggest starting by working right through a good tutorial such as
railstutorial.org (which is free to use online).

As for your error, many here, including myself, would suggest that you
do not try to do rails development on Windows. Instead use a linux
variety such as Ubuntu, or a Mac. Some have had success on Windows,
but many more have not. You can either dual boot your machine with
ubuntu and Win or run ubuntu in a virtual machine in windows (using
virtual box or vmware for example). Then I use rvm to install ruby
and rails.

Colin

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs