Error when starting rails server [on rails 3]

Hi all,

I receive an error when starting the server, namely:

~/Documents/blog$ rails server
/usr/local/lib/site_ruby/1.8/rubygems.rb:827:in report_activate_error': RubyGem version error: rack-mount(0.5.0 not ~> 0.4.0) (Gem::LoadError) from /usr/local/lib/site_ruby/1.8/rubygems.rb:261:inactivate’
from /usr/local/lib/site_ruby/1.8/rubygems.rb:296:in activate' from /usr/local/lib/site_ruby/1.8/rubygems.rb:295:ineach’
from /usr/local/lib/site_ruby/1.8/rubygems.rb:295:in activate' from /usr/local/lib/site_ruby/1.8/rubygems.rb:296:inactivate’
from /usr/local/lib/site_ruby/1.8/rubygems.rb:295:in each' from /usr/local/lib/site_ruby/1.8/rubygems.rb:295:inactivate’
from /usr/local/lib/site_ruby/1.8/rubygems.rb:68:in `gem’
from /usr/bin/rails:18

Some background.

  • I run Ubuntu Linux (via Windows Virtual PC)

  • I did a clean install of rails3. Though I ran into trouble with
    sqlite3-ruby. It turned out I did not install ruby1.8-dev. However in
    sorting this out I added other gems as well. I guess a gem is not
    confured correctly. So I ran gem clean. The error remains though. My
    list of gems is:

  • *** LOCAL GEMS ***

abstract (1.0.0)
actionmailer (3.0.0.beta)
actionpack (3.0.0.beta)
activemodel (3.0.0.beta)
activerecord (3.0.0.beta)
activeresource (3.0.0.beta)
activesupport (3.0.0.beta)
arel (0.2.1)
builder (2.1.2)
bundler (0.9.3)
erubis (2.6.5)
i18n (0.3.3)
mail (2.1.2)
memcache-client (1.7.8)
mime-types (1.16)
rack (1.1.0)
rack-mount (0.5.0)
rack-test (0.5.3)
rails (3.0.0.beta)
railties (3.0.0.beta)
rake (0.8.7)
sqlite3-ruby (1.2.5)
text-format (1.0.0)
text-hyphen (1.0.0)
thor (0.13.0)
tzinfo (0.3.16)

ANY HELP is much appreciated.
Thanks.

J.

On Wed, Feb 10, 2010 at 6:56 PM, Joep A. [email protected] wrote:

RubyGem version error: rack-mount(0.5.0 not ~> 0.4.0) (Gem::LoadError)

gem install rack-mount -v=0.4.0


Greg D.
destiney.com | gregdonald.com

Great; this worked like a charm. Thanks.

Funny how the rails 3 beta app works better with an older version of
this gem.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs