Error when running GNU radio built from script

Dear,
I installed GNU radio from build_gnuradio script successful.
Then I tried a simple FM receiver and I got this warning :

UHD Warning:
Could not locate USRP1 firmware. Please run:
“/usr/local/lib/uhd/utils/uhd_images_downloader.py”

Then as it said, I tried to run that .py file and got this :

Traceback (most recent call last):
File “./uhd_images_downloader”, line 26, in
import requests
ImportError: No module named requests

Could you please help me with this ? Im using USRP1.
Before that, I used to install GNU radio from apt-get, I got exactly
problem, then I ran uhd_images_downloader from /usr/lib/utils and it
worked. I also tried this time, it downloaded the images, but when i run
GNU radio the same thing happen.

Thanks

Hi Hoang,

current UHD master uses the “requests” python library. I think we might
be forgetting to cleanly document and check that requirement; hence,
build-gnuradio doesn’t automatically install that library.

I don’t know which distribution you are using, but if you’re using
fedora, you can “yum install python-requests”.

Best regards,
Marcus

Sorry for not reply sooner,
I also figure out that python need request library,
Then I install it. and the problem was fixed.
following is way I install requests library:

install python pip : sudo apt-get install python-pip
install requests lib : sudo pip install requests

Thank you Marcus

On Thu, Aug 13, 2015 at 1:36 PM, Marcus Müller
[email protected]

Hi!

Don’t worry, that’s something everyone is happy about when noticed.
For future readers:
sudo apt-get install python-requests
should have worked too (and is preferable, usually, because it allows
your distribution to keep the library up-to-date).

Best regards,
Marcus

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs