Error when loading wxruby

I’ve had plenty of wonderful experience with WxRuby on a PC, but
whenever I try it on my Ubuntu Linux, I get the same error. I’ve tried
two different computers, and they do the same thing, so I’m wondering if
it’s an error within Wx. This is the error I get:

/var/lib/gems/1.9.1/gems/wxruby-ruby19-2.0.0-x86_64-linux/lib/wx.rb:12:in
`require’: libwx_gtk2u_stc-2.8.so.0: cannot open shared object file: No
such file or directory -
/var/lib/gems/1.9.1/gems/wxruby-ruby19-2.0.0-x86_64-linux/lib/wxruby2.so
(LoadError)

from
/var/lib/gems/1.9.1/gems/wxruby-ruby19-2.0.0-x86_64-linux/lib/wx.rb:12:in
`<top (required)>’

from /home/username/Documents/Projects/Ruby/ProjectName/lib/main.rb:1:in
`require’

from /home/username/Documents/Projects/Ruby/ProjectName/lib/main.rb:1:in
`’

I’m using Ubuntu 10.04, NetBeans 6.9, Ruby 1.9.1, RubyGems 1.3.5, and
everything sees each other just perfectly. No problems with the RubyGems
platform in NetBeans. However, as you see from the error, WxRuby19 is
version 2.0.0 instead of 2.0.1, and for whatever reason, when I try to
install 2.0.1 it jumps back to 2.0.0, and when I try to update, it says
‘nothing to update’. Should I unpack the 2.0.1 archive manually into the
rubygems directory, and see if that fixes anything?

  • Hameed

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs