Error when installing on Godaddy Shared Linux

I’m attempting to install Radiant onto a Godaddy Shared Linux account
(Java server with SSH access) but keep banging my head against a wall.
Do note that I’m not a ruby person, so I’m simply following
instructions and what google has spat out.

Apparently when installing gem compiles the scripts to native code
using make, gcc, and several other commands. I’ve had to manually
download and add make and gcc to my PATH.

System specs
-OS: CentOS release 5.2 (Final)
-Linux Kernel version: 2.6.18-164.15.1.el5PAE
-Ruby version: ruby 1.8.4 (2005-12-24) [i686-linux]
-Gem version: 1.3.7
-Make version: GNU Make 3.81 (3.81-3.el5.i386)
-Gcc version: 4.1.2-48.el5.i386

Here’s what happens

[[name]@p3nlhjava006 html]$ gem install radiant
Building native extensions. This could take a while…
ERROR: Error installing radiant:
ERROR: Failed to build gem native extension.

/usr/local/bin/ruby extconf.rb install radiant
creating Makefile

make
make: Warning: File `Makefile’ has modification time 0.037 s in the
future
gcc -fPIC -g -O2 -O2 -I. -I/usr/local/lib/ruby/1.8/i686-linux -I/usr/
local/lib/ruby/1.8/i686-linux -I. -c redcloth_attributes.c
gcc -fPIC -g -O2 -O2 -I. -I/usr/local/lib/ruby/1.8/i686-linux -I/usr/
local/lib/ruby/1.8/i686-linux -I. -c redcloth_inline.c
gcc -fPIC -g -O2 -O2 -I. -I/usr/local/lib/ruby/1.8/i686-linux -I/usr/
local/lib/ruby/1.8/i686-linux -I. -c redcloth_scan.c
gcc -shared -L’/usr/local/lib’ -Wl,-R’/usr/local/lib’ -o
redcloth_scan.so redcloth_attributes.o redcloth_inline.o
redcloth_scan.o -ldl -lcrypt -lm -lc
make: warning: Clock skew detected. Your build may be incomplete.

make install
gcc -fPIC -g -O2 -O2 -I. -I/usr/local/lib/ruby/1.8/i686-linux -I/usr/
local/lib/ruby/1.8/i686-linux -I. -c redcloth_attributes.c
gcc -fPIC -g -O2 -O2 -I. -I/usr/local/lib/ruby/1.8/i686-linux -I/usr/
local/lib/ruby/1.8/i686-linux -I. -c redcloth_inline.c
gcc -fPIC -g -O2 -O2 -I. -I/usr/local/lib/ruby/1.8/i686-linux -I/usr/
local/lib/ruby/1.8/i686-linux -I. -c redcloth_scan.c
gcc -shared -L’/usr/local/lib’ -Wl,-R’/usr/local/lib’ -o
redcloth_scan.so redcloth_attributes.o redcloth_inline.o
redcloth_scan.o -ldl -lcrypt -lm -lc
/usr/bin/install -c -m 0755 redcloth_scan.so /home/content/i/h/a/
[name]/.gems/gems/RedCloth-4.2.3/lib
/usr/bin/install: cannot stat `redcloth_scan.so’: No such file or
directory
make: *** [/home/content/i/h/a/[name]/.gems/gems/RedCloth-4.2.3/lib/
redcloth_scan.so] Error 1

Gem files will remain installed in /home/content/i/h/a/[name]/.gems/
gems/RedCloth-4.2.3 for inspection.
Results logged to /home/content/i/h/a/[name]/.gems/gems/RedCloth-4.2.3/
ext/redcloth_scan/gem_make.out


Interestingly enough, running gem install RedCloth produces the exact
same output:

[[name]@p3nlhjava006 radiant.wreckcreations.biz]$ gem install RedCloth
Building native extensions. This could take a while…
ERROR: Error installing RedCloth:
ERROR: Failed to build gem native extension.

/usr/local/bin/ruby extconf.rb install RedCloth
creating Makefile

make
make: Warning: File `Makefile’ has modification time 0.069 s in the
future
gcc -fPIC -g -O2 -O2 -I. -I/usr/local/lib/ruby/1.8/i686-linux -I/usr/
local/lib/ruby/1.8/i686-linux -I. -c redcloth_attributes.c
gcc -fPIC -g -O2 -O2 -I. -I/usr/local/lib/ruby/1.8/i686-linux -I/usr/
local/lib/ruby/1.8/i686-linux -I. -c redcloth_inline.c
gcc -fPIC -g -O2 -O2 -I. -I/usr/local/lib/ruby/1.8/i686-linux -I/usr/
local/lib/ruby/1.8/i686-linux -I. -c redcloth_scan.c
gcc -shared -L’/usr/local/lib’ -Wl,-R’/usr/local/lib’ -o
redcloth_scan.so redcloth_attributes.o redcloth_inline.o
redcloth_scan.o -ldl -lcrypt -lm -lc
make: warning: Clock skew detected. Your build may be incomplete.

make install
gcc -fPIC -g -O2 -O2 -I. -I/usr/local/lib/ruby/1.8/i686-linux -I/usr/
local/lib/ruby/1.8/i686-linux -I. -c redcloth_attributes.c
gcc -fPIC -g -O2 -O2 -I. -I/usr/local/lib/ruby/1.8/i686-linux -I/usr/
local/lib/ruby/1.8/i686-linux -I. -c redcloth_inline.c
gcc -fPIC -g -O2 -O2 -I. -I/usr/local/lib/ruby/1.8/i686-linux -I/usr/
local/lib/ruby/1.8/i686-linux -I. -c redcloth_scan.c
gcc -shared -L’/usr/local/lib’ -Wl,-R’/usr/local/lib’ -o
redcloth_scan.so redcloth_attributes.o redcloth_inline.o
redcloth_scan.o -ldl -lcrypt -lm -lc
/usr/bin/install -c -m 0755 redcloth_scan.so /home/content/i/h/a/
ihammerhands/.gems/gems/RedCloth-4.2.3/lib
/usr/bin/install: cannot stat `redcloth_scan.so’: No such file or
directory
make: *** [/home/content/i/h/a/ihammerhands/.gems/gems/RedCloth-4.2.3/
lib/redcloth_scan.so] Error 1

Gem files will remain installed in /home/content/i/h/a/
ihammerhands/.gems/gems/RedCloth-4.2.3 for inspection.
Results logged to /home/content/i/h/a/ihammerhands/.gems/gems/
RedCloth-4.2.3/ext/redcloth_scan/gem_make.out


I’m at a loss here, and I’m not familiar enough with Ruby to
troubleshoot it myself. So I hope that somebody here can help.

Before you say it, switching hosts or plans isn’t possible. Getting a
separate plan at another friendly host and redirecting there isn’t an
option either. This is only for one website, so it shouldn’t be all
that hard.

Thanks

On Sun, Oct 17, 2010 at 4:35 PM, Lord.Quackstar
[email protected] wrote:


make: *** [/home/content/i/h/a/[name]/.gems/gems/RedCloth-4.2.3/lib/
redcloth_scan.so] Error 1

i can’t be of any help figuring out how to compile stuff on a godaddy
server but to skip the RedCloth installation altogether try:

gem install rake will_paginate
gem install rack -v 1.1.0
gem install radiant --ignore-dependencies

this will cause Radiant to fallback on its vendored (older, pure ruby)
RedCloth.

I think I might of gotten it installed (had to move to a new server),
but now I’m getting another problem: Something is redirecting to the
wrong directory.

When visiting the root directory of my site I get a directory list.
Then when I go to /public I get a 404 about /
radiant.wreckcreations.biz/public/dispatch.fcgi . Interestingly though
I get this in my apache error log:

[Mon Oct 18 08:05:29 2010] [error] [client 74.131.61.13] File does not
exist: /var/chroot/home/content/i/h/a/[name]/html/
radiant.wreckcreations.biz/radiant.wreckcreations.biz/public/
dispatch.fcgi

Apparently something is redirecting to the wrong directory. But I have
no idea what it is as none of the .htaccess’s in the hearchy redirect
there. I tried to bandaid fix it by putting this in /.htaccess:

RewriteCond %{REQUEST_URI} ^/radiant.wreckcreations.biz/radiant
.wreckcreations.biz [NC]
RewriteRule ^(.*)$ /radiant.wreckcreations.biz/$1 [L,QSA,NC]

But it didn’t seem to fix it. I’m really at a loss now and don’t have
the ruby skills to manually fix it. From what I’ve heard Godaddy
doesn’t help with this kind of stuff, so I don’t have anybody else to
turn to.

Any suggestions?

Something else: When visiting dispatch.fcgi directly (managed to
rewrite an empty URL to dispatch.fcgi) it sits there for about 20
seconds then gives:

Application error
Rails application failed to start properly"

Apache logs say:
[Mon Oct 18 08:23:12 2010] [error] [client 74.131.61.13] FastCGI: comm
with (dynamic) server “/var/chroot/home/content/i/h/a/[name]/html/
radiant.wreckcreations.biz/public/dispatch.fcgi” aborted: (first read)
idle timeout (60 sec)
[Mon Oct 18 08:23:12 2010] [error] [client 74.131.61.13] FastCGI:
incomplete headers (0 bytes) received from server “/var/chroot/home/
content/i/h/a/[name]/html/radiant.wreckcreations.biz/public/
dispatch.fcgi”

I’ve verified all the database stuff and htaccess files, but can’t get
it to work. Any other suggestions?

On Oct 18, 11:16am, “Lord.Quackstar” [email protected]

Lord.Quackstar said the following on 10/18/2010 11:16 AM:

exist: /var/chroot/home/content/i/h/a/[name]/html/

But it didn’t seem to fix it. I’m really at a loss now and don’t have
the ruby skills to manually fix it. From what I’ve heard Godaddy
doesn’t help with this kind of stuff, so I don’t have anybody else to
turn to.

Any suggestions?

I use Dreamhost and this makes perfect sense to me.

You seem to have a setup/config error.
I’m not sure why you should be able to browse the root of your account.

You are chroot’d and that part of the path that apache’s logs report you
should ignore. Apache is reporting the ABSOLUTE address on the file
system since the way it is set up to deal with ‘virtual domains’ (see
the Apache documentation) has to suport you and all other users.

You, however, are in what amounts to a ‘virtual partition’ (NOT a
Virtual Machine) that begins at an absolute address of, I think

/var/chroot/home/content/i/h/a/[name]/html/radiant.wreckcreations.biz/

or perhaps

/var/chroot/home/content/i/h/a/[name]/

Apache “knows” this and is already remapping your addresses.
This setup is in the system level and is not under your control and is a
function of the fact you are using shared resource and the measures that
the operators have taken to isolate each user so as to prevent them
doing things that may harm one another. Using Chroot to isolate is a
standard and well established method.

Your addition remapping just scr3ws-the-p00ch. Take it out.

I install in my home directory, but the apache server looks for what’s
under /public.

That is http://www.systemI.ca/
maps to ~antonaylward/www.systemi.ca/public/

WITHOUT ME DOING ANYTHING.

I think you are over-engineering this.
Check the docs to see.

If I were experimenting I’d wipe (or move to one side)
the just list some plain texr files under /public/ and see what happens
when you ftp - YES FTP does handle http - to radiant.wreckcreations.biz

Oh, and get rid of that redirect first.
You really should’nt need the double-domainname like that AT ALL.
Its a side effect of an incorrect set-up.

I suggest you go to the domain “control panel” and see where the base is
set. You might see a form something like

                               +-----------+
Web directory:  /home/username/|           |
                               +-----------+

That’s where you need to put the path to the "/public’
In my case it looks like

                               +-----------------------+
Web directory:  /home/username/|www.systemI.ca/public/ |
                               +-----------------------+

THAT is where the web browser gets pointed.

I can’t be sure, not being a subscriber, that the GoDaddy looks exactly
the same.

Officially, Dreamhost isn’t “Rails-Friendly”. In practice they are, its
that they don’t help with the actual application. But setting up Rails,
Passenger and the like they’ve always helped with. And they have a good
support Wiki.

Well I went ahead and pointed Godaddy to the /public folder but am now
getting a 500 from a misbehaving looping redirect.

First I think I should explain some stuff
-All website files exist under /var/chroot/home/content/i/h/a/[name]/
html/
–I have access to this and other directories upstream
–There is a .htaccess file here but it doesn’t do anything to this
domain. I’ve temporarily disabled it and it still didn’t work
-Radiant is installed to /var/chroot/home/content/i/h/a/[name]/html/
radiant.wreckcreations.biz/
–There is no .htaccess here
-A request for radiant.wreckcreations.biz goes to /var/chroot/home/
content/i/h/a/[name]/html/radiant.wreckcreations.biz/public/
–Default .htaccess file exists here
–I’ve disabled this .htaccess and I get a directory list (temporarily
turned on for all my websites). Enabled gives a 500 and a max
redirects error.

And before you say it: I’ve already changed the appropriate
permissions on all applicable directories/files using instructions
from here:
http://6brand.com/application-error-rails-app-failed-to-start-properly.html

This is confusing as I’m using the default .htaccess. According to a
generic help page I should set the rewrite base to /, but that only
gives a timeout:

[Tue Oct 19 17:10:42 2010] [error] [client 74.131.61.13] FastCGI: comm
with (dynamic) server “/var/chroot/home/content/i/h/a/[name]/html/
radiant.wreckcreations.biz/public/dispatch.fcgi” aborted: (first read)
idle timeout (60 sec)
[Tue Oct 19 17:10:42 2010] [error] [client 74.131.61.13] FastCGI:
incomplete headers (0 bytes) received from server “/var/chroot/home/
content/i/h/a/[name]/html/radiant.wreckcreations.biz/public/
dispatch.fcgi”

Any other suggestions?

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs