Error using Tk

Hello everybody !

When I try to use the Tk extension I get an error that the “tk84.dll”
can’t be found.
I tried to reinstall it but I didn’t find the right gem.
So which gem is it or is there another way to get Tk running ???

Dominik

On Jun 23, 8:32 pm, [email protected] wrote:

Hello everybody !

When I try to use the Tk extension I get an error that the “tk84.dll”
can’t be found.
I tried to reinstall it but I didn’t find the right gem.
So which gem is it or is there another way to get Tk running ???

Dominik

Install tk first.
http://tcl.activestate.com/software/tcltk/

Thanks a lot !
It’s working now.

Dominik

2007/6/23, akbarhome [email protected]:

On Jun 23, 9:44 am, [email protected] wrote:

When I try to use the Tk extension I get an error that the “tk84.dll”
can’t be found.
I tried to reinstall it but I didn’t find the right gem.
So which gem is it or is there another way to get Tk running ???

Dominik

Install tk first.
http://tcl.activestate.com/software/tcltk/

I am having similar problems with Ruby and Tk, I installed Tcl (which
appeared to be successful), and it still is not working. I receive
several errors. I even attempted to copy the tk84.dll into the Ruby/
bin folder as I had seen suggested somewhere else, but that didn’t
work either. Any other suggestions?

This is what I am getting…

C:\ruby>canvas.rb
c:/ruby/lib/ruby/1.8/tk.rb:1102:in `initialize’: Can’t find a usable
init.tcl in
the following directories: (RuntimeError)
c:/ruby/lib/tcl8.4 c:/ruby/lib/tcl8.4 c:/lib/tcl8.4 c:/ruby/
library c:/library c:/tcl8.4.15/library

This probably means that Tcl wasn’t installed properly.
from c:/ruby/lib/ruby/1.8/tk.rb:1102:in new' from c:/ruby/lib/ruby/1.8/tk.rb:1102 from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb: 27:inge
m_original_require’
from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
27:in `re
quire’
from C:/ruby/canvas.rb:1

On Jul 30, 10:02 pm, joviyach [email protected] wrote:

Install tk first.
C:\ruby>canvas.rb
27:in ge m_original_require' from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb: 27:inre
quire’
from C:/ruby/canvas.rb:1

This is now working.

I copied also the tk8.4 folder from the Tcl\lib directory to the ruby
\lib directory. That resolved the issue.