Error starting WEBrick after environment.rb modification

This started for me after I umcommented
config.action_controller.session_store = :active_record_store line in
environment.rb

C:\ruby\projects\depot>ruby script/server => Booting
WEBrick…/script/…/config/…/config/environment.rb:35: undefined
method action_controller' for Config:Module (NoMethodError) from ./script/../config/../vendor/rails/railties/lib/initializer.rb:40:inrun’
from ./script/…/config/…/config/environment.rb:13
from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
require' from ./script/../config/../vendor/rails/activesupport/lib/active_support/dependencies.rb:400:inrequire’
from
./script/…/config/…/vendor/rails/railties/lib/commands/servers/webrick.rb:52
from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
require' from ./script/../config/../vendor/rails/activesupport/lib/active_support/dependencies.rb:400:inrequire’
from
./script/…/config/…/vendor/rails/railties/lib/commands/server.rb:39
from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`require’
from script/server:3

any ideas?

I am currently using the latest EdgeRails revison 5375

can someone please help me in this matter?

Hi,

I had the same problem and it was because the ‘c’ in config was
capitalized:
Config.action_controller.session_store = :active_record_store

Once I changed it, WEBrick started up fine.

JP

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs