Error starting OpenID server by EastMedia (PIP)

Hi,
I was just trying to run the EastMedia OpenID server
(http://identity.eastmedia.com/identity/show/Rails+OpenID+Server),
but I get the following error following the INSTALL inside the dist.:

C:\rails_apps\pip>rake db:migrate
(in C:/rails_apps/pip)

  *******************************************************************
  * config.breakpoint_server has been deprecated and has no effect.
  • *******************************************************************
    

rake aborted!
no such file to load – breakpoint

Does anybody know who/where can I look for fix that ?

Thank’s in advance LGS
MY ENV:

C:\rails_apps\pip>rails -v
Rails 1.2.3

C:\rails_apps\pip>ruby -v
ruby 1.8.6 (2007-03-13 patchlevel 0) [i386-mswin32]

… more trace :

C:\rails_apps\pip>rake db:migrate --trace
(in C:/rails_apps/pip)
** Invoke db:migrate (first_time)
** Invoke environment (first_time)
** Execute environment

  *******************************************************************
  * config.breakpoint_server has been deprecated and has no effect.
  • *******************************************************************
    

rake aborted!
no such file to load – breakpoint
C:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
gem_original_ quire' C:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:inrequire’
C:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.4.2.6747/lib/active_support/dep
dencies.rb:495:in require' C:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.4.2.6747/lib/active_support/dep dencies.rb:342:innew_constants_in’
C:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.4.2.6747/lib/active_support/dep
dencies.rb:495:in require' C:/rails_apps/pip/vendor/plugins/engines/lib/engines/migration_extensions.rb:2 C:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:ingem_original_
quire’
C:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
require' C:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.4.2.6747/lib/active_support/dep dencies.rb:495:inrequire’
C:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.4.2.6747/lib/active_support/dep
dencies.rb:342:in new_constants_in' C:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.4.2.6747/lib/active_support/dep dencies.rb:495:inrequire’
C:/rails_apps/pip/vendor/plugins/engines/lib/engines.rb:463
C:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
gem_original_ quire' C:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:inrequire’
C:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.4.2.6747/lib/active_support/dep
dencies.rb:495:in require' C:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.4.2.6747/lib/active_support/dep dencies.rb:342:innew_constants_in’
C:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.4.2.6747/lib/active_support/dep
dencies.rb:495:in require' C:/rails_apps/pip/vendor/plugins/engines/init.rb:32:inevaluate’
C:/ruby/lib/ruby/gems/1.8/gems/rails-1.2.3.6747/lib/rails/plugin/loader.rb:107
n evaluate' C:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.4.2.6747/lib/active_support/cor ext/kernel/reporting.rb:11:insilence_warnings’
C:/ruby/lib/ruby/gems/1.8/gems/rails-1.2.3.6747/lib/rails/plugin/loader.rb:107
n evaluate' C:/ruby/lib/ruby/gems/1.8/gems/rails-1.2.3.6747/lib/rails/plugin/loader.rb:24:load’
C:/ruby/lib/ruby/gems/1.8/gems/rails-1.2.3.6747/lib/initializer.rb:193:in
loa plugins' C:/ruby/lib/ruby/gems/1.8/gems/rails-1.2.3.6747/lib/rails/plugin/locator.rb:16 neach’
C:/ruby/lib/ruby/gems/1.8/gems/rails-1.2.3.6747/lib/rails/plugin/locator.rb:16
n each' C:/ruby/lib/ruby/gems/1.8/gems/rails-1.2.3.6747/lib/initializer.rb:192:inloa
plugins’
C:/ruby/lib/ruby/gems/1.8/gems/rails-1.2.3.6747/lib/initializer.rb:191:in
`eac

C:/ruby/lib/ruby/gems/1.8/gems/rails-1.2.3.6747/lib/initializer.rb:191:in
loa plugins' C:/ruby/lib/ruby/gems/1.8/gems/rails-1.2.3.6747/lib/initializer.rb:111:inpro
ss’
C:/ruby/lib/ruby/gems/1.8/gems/rails-1.2.3.6747/lib/initializer.rb:49:in
send C:/ruby/lib/ruby/gems/1.8/gems/rails-1.2.3.6747/lib/initializer.rb:49:inrun’
C:/rails_apps/pip/config/environment.rb:27
C:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
gem_original_ quire' C:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:inrequire’
C:/ruby/lib/ruby/gems/1.8/gems/rails-1.2.3.6747/lib/tasks/misc.rake:3
C:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:392:in call' C:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:392:inexecute’
C:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:392:in each' C:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:392:inexecute’
C:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:362:in invoke' C:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:355:insynchronize’
C:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:355:in invoke' C:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:369:ininvoke_prerequis
es’
C:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1003:in each' C:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1003:insend’
C:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1003:in each' C:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:368:ininvoke_prerequis
es’
C:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:361:in invoke' C:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:355:insynchronize’
C:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:355:in invoke' C:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1739:intop_level’
C:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1739:in each' C:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1739:intop_level’
C:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1761:in
standard_except n_handling' C:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1733:intop_level’
C:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1711:in run' C:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1761:instandard_except
n_handling’
C:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1708:in run' C:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/bin/rake:7 C:/ruby/bin/rake.bat:20:inload’
C:/ruby/bin/rake.bat:20

Luca g. Soave wrote:

Hi,
I was just trying to run the EastMedia OpenID server
(http://identity.eastmedia.com/identity/show/Rails+OpenID+Server),
but I get the following error following the INSTALL inside the dist.:

C:\rails_apps\pip>rake db:migrate
(in C:/rails_apps/pip)

  *******************************************************************
  * config.breakpoint_server has been deprecated and has no effect.
  • *******************************************************************
    

rake aborted!
no such file to load – breakpoint

Does anybody know who/where can I look for fix that ?

Thank’s in advance LGS
MY ENV:

C:\rails_apps\pip>rails -v
Rails 1.2.3

C:\rails_apps\pip>ruby -v
ruby 1.8.6 (2007-03-13 patchlevel 0) [i386-mswin32]

… more trace :

C:\rails_apps\pip>rake db:migrate --trace
(in C:/rails_apps/pip)
** Invoke db:migrate (first_time)
** Invoke environment (first_time)
** Execute environment

  *******************************************************************
  * config.breakpoint_server has been deprecated and has no effect.
  • *******************************************************************
    

rake aborted!
no such file to load – breakpoint
.
.
.

Hi all,
I’ve been looking around a little bit and … :

  1. PIP trunk by EastMedia use “old” Engines rchitecture 1.1.4
    http://svn.apache.org/repos/asf/incubator/heraldry/idp/pip/trunk/vendor/plugins/engines/CHANGELOG
    which means, you’ve to freeze rails version TAG_rel_1-1-6, if you wanna
    work like that.

Well I did.
I was able to finally start the server but something still doesn’t work
: CAPTCHA !
The log, say the captcha_helper.rb is missing but can’t still be able to
figure out
what they’re using for captcha, not engines nor plugins, may be
something installed server side like captcha gem.
But how can I know that ?

I’m also planning to :

  1. remove the old engine and install the 1.2 by James A.
    (http://rails-engines.org/)

  2. freeze rails 1.2.3

  3. retry … time permitting

    See you guys
    Luca G.S.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs