Error running Mongrel on Ruby 1.9

Hi,

I have a problem running Mongrel, I’m using the latest ruby 1.9 and
rails 2.3.5

when I start the server (I’m using Aptana IDE), on mongrel, here is the
output:

C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in
require': 126: The specified module could not be found. - C:/Ruby19/lib/ruby/gems/1.9.1/gems/mongrel-1.1.5-x86-mingw32/lib/http11.so (LoadError) from C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:inblock in require’
from
C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:521:in
new_constants_in' from C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:inrequire’
from
C:/Ruby19/lib/ruby/gems/1.9.1/gems/mongrel-1.1.5-x86-mingw32/lib/mongrel.rb:12:in
<top (required)>' from C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:inrequire’
from
C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in
block in require' from C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:521:innew_constants_in’
from
C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in
require' from C:/Ruby19/lib/ruby/gems/1.9.1/gems/rack-1.0.1/lib/rack/handler/mongrel.rb:1:in<top (required)>’
from
C:/Ruby19/lib/ruby/gems/1.9.1/gems/rack-1.0.1/lib/rack/handler.rb:17:in
const_get' from C:/Ruby19/lib/ruby/gems/1.9.1/gems/rack-1.0.1/lib/rack/handler.rb:17:inblock in get’
from
C:/Ruby19/lib/ruby/gems/1.9.1/gems/rack-1.0.1/lib/rack/handler.rb:17:in
each' from C:/Ruby19/lib/ruby/gems/1.9.1/gems/rack-1.0.1/lib/rack/handler.rb:17:inget’
from
C:/Ruby19/lib/ruby/gems/1.9.1/gems/rails-2.3.5/lib/commands/server.rb:45:in
`<top (required)>’

any help?

Hi all,

I have the same problem here…

Did you found any solution?

ty

Not sure what’s causing the problem, but I think thin and passenger
are pretty widely preferred over mongrel these days – might want to
give one of those a shot.

On Tue, Feb 9, 2010 at 16:29, Alessandro Queiroz

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs