Error re-deploying rails app with capistrano


#1

Hello all,

I’m having a problem re-deploying a rails app with capistrano. It has
been working fine previously but now it’s running into the following
error:

“command “sudo chgrp -R /var/www/apps/mountainboardmag.co.uk/current/
tmp /var/www/apps/mountainboardmag.co.uk/shared” failed on
www.mountainboardmag.co.uk

My capistrano deploy log looks like:

cap deploy

Any help would be much appreciated!

Thanks,

Alastair


#2

Well, it looks to me as though the group argument’s missing from the
chgrp command. Is set_perms_for_mongrel_dirs one of your own tasks?
Can you post any elements of your recipe to clarify?

-Chrisl


#3

I just started getting this error myself, also with my tmp directory.
I have deployed this application numerous times for the past few
months, and suddenly its failing.

“set_perms_for_mongrel_dirs” is a Capistrano recipe that comes with
mongrel or mongrel_cluster, i believe. Is there a nice way that i can
ask Capistrano what tasks it knows about or something? I’ll get its
source if i can find it…

Recently i did a gem update, which i know took me from Rails 1.2.2 to
1.2.3, but i’m not sure what else it did. All i know is that
everything seems fine until i deploy…


#4

On Jul 13, 9:30 am, Chrisl removed_email_address@domain.invalid wrote:

Well, it looks to me as though the group argument’s missing from the
chgrp command. Is set_perms_for_mongrel_dirs one of your own tasks?
Can you post any elements of your recipe to clarify?

Well it turns out it was an issue with the deprec gem i’d installed.
All is back and working again.

Alastair