Error & Question about audio_alsa_sink

Hi all,

I have a question about one of the examples in GNUradio 3.2.2 under
Ubuntu9.04. I tried to run usrp_nbfm_rcv.py to test the usrp board.
However,
I met the following errors:

Using RX d’board A: Flex 2400 Rx MIMO B
len(rx_chan_coeffs) = 397

gr_fir_ccc: using SSE
len(audio_taps) = 423

gr_fir_fff: using SSE
audio_alsa_sink[hw:0,0]: unable to support sampling rate 32000
card requested 44100 instead.
audio_alsa_sink[hw:0,0]: set_period_time_near failed: Invalid argument

Traceback (most recent call last):
File “usrp_nbfm_rcv.py”, line 382, in
app = stdgui2.stdapp (my_top_block, “USRP NBFM RX”)
File “/usr/lib/python2.6/dist-packages/gnuradio/wxgui/stdgui2.py”, line
36,
in init
wx.App.init (self,* redirect=False*)

File…

return _audio_alsa.sink(*args, **kwargs)
RuntimeError: audio_alsa_sink

I found that someone met the similar problems as I have. And the answer
from
Johnathan is that the sound card is in use by some other application,
possibly a previous run of a GNU Radio application that didn’t exit
cleanly.

I tried to restart the system and re-run the program but the error is
still
there. So I guess the sound card may not be used by some other
application,
but something else such as configuration of sound card…?
BTW, I also run this program on another computer, and it can get
through!
But I still have no idea why I still have the error above in my first
run.
Can any one help me with this question? Thanks in advance!

Sincerely,

Yuan

On Wed, Jul 22, 2009 at 10:11, Milo W.[email protected] wrote:

audio_alsa_sink[hw:0,0]: unable to support sampling rate 32000
card requested 44100 instead.

The real issue here is the sound card in your machine doesn’t support
the 32000 sampling rate. However, the ALSA driver has an internal
resampler, so you can run:

$ usrp_nbfm_rcv.py [other options] -O plughw:0,0

The -O parameter tells the ALSA driver which hardware device to use,
and ‘plughw’ is the name of the resampler.

If that works, then you can make this the default, but setting it in a
GNU Radio configuration file.

Edit ~/.gnuradio/config.conf (create it if necessary), and add or edit
the following section:

[audio_alsa]
default_output_device = plughw:0,0

Johnathan

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs