Error make usrp


#1

Hi, everyone.
I have problems with installing usrp when i give a command make.
The error like this:
[root@lss-67-119 usrp-0.12]# make
make all-recursive
make[1]: Entering directory /home/usrp/usrp-0.12' Making all in config make[2]: Entering directory/home/usrp/usrp-0.12/config’
make[2]: Nothing to be done for all'. make[2]: Leaving directory/home/usrp/usrp-0.12/config’
Making all in host
make[2]: Entering directory /home/usrp/usrp-0.12/host' Making all in misc make[3]: Entering directory/home/usrp/usrp-0.12/host/misc’
make[3]: Nothing to be done for all'. make[3]: Leaving directory/home/usrp/usrp-0.12/host/misc’
Making all in lib
make[3]: Entering directory /home/usrp/usrp-0.12/host/lib' make all-am make[4]: Entering directory/home/usrp/usrp-0.12/host/lib’
if /bin/sh …/…/libtool --tag=CXX --mode=compile g++ -DHAVE_CONFIG_H
-I.
-I. -I…/… -I…/…/host/lib -I…/…/firmware/include -g -O2 -Wall
-Woverloaded-virtual -MT fusb_linux.lo -MD -MP -MF
“.deps/fusb_linux.Tpo”
-c -o fusb_linux.lo fusb_linux.cc;
then mv -f “.deps/fusb_linux.Tpo” “.deps/fusb_linux.Plo”; else
rm
-f “.deps/fusb_linux.Tpo”; exit 1; fi
g++ -DHAVE_CONFIG_H -I. -I. -I…/… -I…/…/host/lib
-I…/…/firmware/include -g -O2 -Wall -Woverloaded-virtual -MT
fusb_linux.lo -MD -MP -MF .deps/fusb_linux.Tpo -c fusb_linux.cc -fPIC
-DPIC -o .libs/fusb_linux.o
fusb_linux.cc:30:28: error: linux/compiler.h: No such file or directory
make[4]: *** [fusb_linux.lo] Error 1
make[4]: Leaving directory /home/usrp/usrp-0.12/host/lib' make[3]: *** [all] Error 2 make[3]: Leaving directory/home/usrp/usrp-0.12/host/lib’
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory /home/usrp/usrp-0.12/host' make[1]: *** [all-recursive] Error 1 make[1]: Leaving directory/home/usrp/usrp-0.12’
make: *** [all] Error 2
[root@lss-67-119 usrp-0.12]#

Can someone help me?

Thanks

mahendra


#2

On Sat, Feb 24, 2007 at 01:38:43PM +0700, removed_email_address@domain.invalid wrote:

Making all in host
-I. -I…/… -I…/…/host/lib -I…/…/firmware/include -g -O2 -Wall
make[4]: Leaving directory `/home/usrp/usrp-0.12/host/lib’

Thanks
mahendra

Use up-to-date usrp code. This was fixed long ago.

Note that usrp-0.12 is not current.

See http://gnuradio.org/trac/wiki for pointers to svn and/or tarballs.

Eric