Error loading rubygems

Hi,

During an operation (rspec related) that required loading rubygems
(from config/boot.rb file) I got the following error message:

~/config/boot.rb:1:in require': no such file to load -- rubygems (LoadError) ~/config/boot.rb:1 from ~/config/application.rb:1:inrequire’
from ~/config/application.rb:1
from ~/config/environment.rb:2:in require' from ~/config/environment.rb:2 from ~/spec/spec_helper.rb:3:inrequire’
from ~/spec/spec_helper.rb:3
from ~/spec/models/user_spec.rb:1:in require' from ~/spec/models/user_spec.rb:1 from /usr/lib/ruby/1.8/spec/runner/example_group_runner.rb:15:inload’
from /usr/lib/ruby/1.8/spec/runner/example_group_runner.rb:15:in
load_files' from /usr/lib/ruby/1.8/spec/runner/example_group_runner.rb:14:ineach’
from /usr/lib/ruby/1.8/spec/runner/example_group_runner.rb:14:in
load_files' from /usr/lib/ruby/1.8/spec/runner/options.rb:132:inrun_examples’
from /usr/lib/ruby/1.8/spec/runner/command_line.rb:9:in `run’
from /usr/bin/spec:3

I looked for this error on the internet, however they all mentionned
that the problem could come from the existance of multiple versions of
ruby on the machine. Actually that was the case, so I decided to run a
fresh installation of ruby and rails using RVM. But I still have the
same problem!

Additional information:

which ruby
/usr/local/rvm/rubies/ruby-1.9.2-p136/bin/ruby

which rails
/usr/local/rvm/gems/ruby-1.9.2-p136/bin/rails

which gem
/usr/local/rvm/rubies/ruby-1.9.2-p136/bin/gem

gem --version
1.5.0

ls /usr/lib/ruby
1.8 1.9.1 gems
Any idea?

Thanks!

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs