Error installing sns

Following the instructions here (https://github.com/SwankInnovations/
radiant-sns-extension), I encountered this error:

$ rake db:migrate:extensions --trace
(in /home/tom/dev/valchemy1)
** Invoke db:migrate:extensions (first_time)
** Invoke environment (first_time)
** Execute environment
** Execute db:migrate:extensions
rake aborted!
SQLite3::SQLException: no such table: extension_meta: SELECT
schema_version FROM extension_meta WHERE name = ‘Smarty Pants Filter’
/usr/lib/ruby/gems/1.8/gems/radiant-0.9.1/vendor/rails/activerecord/
lib/active_record/connection_adapters/abstract_adapter.rb:221:in log' /usr/lib/ruby/gems/1.8/gems/radiant-0.9.1/vendor/rails/activerecord/ lib/active_record/connection_adapters/sqlite_adapter.rb:172:inexecute’
/usr/lib/ruby/gems/1.8/gems/radiant-0.9.1/vendor/rails/activerecord/
lib/active_record/connection_adapters/sqlite_adapter.rb:417:in
catch_schema_changes' /usr/lib/ruby/gems/1.8/gems/radiant-0.9.1/vendor/rails/activerecord/ lib/active_record/connection_adapters/sqlite_adapter.rb:172:inexecute’
/usr/lib/ruby/gems/1.8/gems/radiant-0.9.1/vendor/rails/activerecord/
lib/active_record/connection_adapters/sqlite_adapter.rb:320:in
select' /usr/lib/ruby/gems/1.8/gems/radiant-0.9.1/vendor/rails/activerecord/ lib/active_record/connection_adapters/abstract/database_statements.rb: 7:inselect_all_without_query_cache’
/usr/lib/ruby/gems/1.8/gems/radiant-0.9.1/vendor/rails/activerecord/
lib/active_record/connection_adapters/abstract/query_cache.rb:62:in
select_all' /usr/lib/ruby/gems/1.8/gems/radiant-0.9.1/vendor/rails/activerecord/ lib/active_record/connection_adapters/abstract/database_statements.rb: 13:inselect_one’
/usr/lib/ruby/gems/1.8/gems/radiant-0.9.1/vendor/rails/activerecord/
lib/active_record/connection_adapters/abstract/database_statements.rb:
19:in select_value' /usr/lib/ruby/gems/1.8/gems/radiant-0.9.1/lib/radiant/ extension_migrator.rb:42:ininitialize_extension_schema_migrations’
/usr/lib/ruby/gems/1.8/gems/radiant-0.9.1/lib/radiant/
extension_migrator.rb:25:in initialize' /usr/lib/ruby/gems/1.8/gems/radiant-0.9.1/vendor/rails/activerecord/ lib/active_record/migration.rb:401:innew’
/usr/lib/ruby/gems/1.8/gems/radiant-0.9.1/vendor/rails/activerecord/
lib/active_record/migration.rb:401:in up' /usr/lib/ruby/gems/1.8/gems/radiant-0.9.1/vendor/rails/activerecord/ lib/active_record/migration.rb:383:inmigrate’
/usr/lib/ruby/gems/1.8/gems/radiant-0.9.1/lib/radiant/
extension_migrator.rb:7:in migrate' /usr/lib/ruby/gems/1.8/gems/radiant-0.9.1/lib/radiant/ extension_migrator.rb:12:inmigrate_extensions’
/usr/lib/ruby/gems/1.8/gems/radiant-0.9.1/lib/radiant/
extension_migrator.rb:11:in each' /usr/lib/ruby/gems/1.8/gems/radiant-0.9.1/lib/radiant/ extension_migrator.rb:11:inmigrate_extensions’
/usr/lib/ruby/gems/1.8/gems/radiant-0.9.1/lib/tasks/extensions.rake:8
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:636:in call' /usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:636:inexecute’
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:631:in each' /usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:631:inexecute’
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:597:in
invoke_with_call_chain' /usr/lib/ruby/1.8/monitor.rb:242:insynchronize’
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:590:in
invoke_with_call_chain' /usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:583:ininvoke’
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2051:in
invoke_task' /usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2029:intop_level’
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2029:in each' /usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2029:intop_level’
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2068:in
standard_exception_handling' /usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2023:intop_level’
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2001:in run' /usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2068:instandard_exception_handling’
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:1998:in run' /usr/lib/ruby/gems/1.8/gems/rake-0.8.7/bin/rake:31 /usr/bin/rake:19:inload’
/usr/bin/rake:19

Thanks in advance for any advice in helping me resolve this.