Error installing gem

Hello everybody !

I just tried to install the “neuro”-gem. But the install process fails
with an exception:

C:\Windows\system32>gem install neuro -y
Building native extensions. This could take a while…
ERROR: While executing gem … (Gem::Installer::ExtensionBuildError)
ERROR: Failed to build gem native extension.

ruby extconf.rb install neuro -y
creating Makefile
E:/Ruby/lib/ruby/1.8/mkmf.rb:1102: warning: global variable `$preload’
not initialized

The command “nmake” couldn’t be found.

Gem files will remain installed in
E:/Ruby/lib/ruby/gems/1.8/gems/neuro-0.4.0 for inspection.
Results logged to

Has anybody why this error occurs and how to solve it ???
Or are there other neuro-network / backpropagation extensions ?


Hello Dominik,

the error you get is due to the fact that the
gem you are trying to install is building the software
from source code.
This is usually done in three steps -

configure/make/make install …
but the Windows version of nmake is not installed on your computer.
You can install a compiler, such as MinGW :

on your system to do the compilation.

This can be useful in many cases anyway…
I haven’t worked with specific backpropagation software, but
if you want to use Ruby for scientific work, some general
numerics software such as Ruby-GSL (
which is included in the one-click installer for Windows

may be helpful.

Best regards,


Thanks for the answer.
I’ll have a look for it.


2007/6/23, Axel E. [email protected]: