Error installing bundler: bundler requires Ruby version >= 2.3.0 - I have 2.6 installed

Hello,

I am super new using linux, and have come to an impass. I am trying to setup a Redmine server, and everything was going along just fine. All of a sudden, I can no longer install anything it seems (bundler, puma, etc) I keep getting the following error: Error installing bundler: bundler requires Ruby version >= 2.3.0

When I run ‘ruby -v’ it is giving me 2.0.0, but ‘rvm list’ displays 2.6.* being my default (2.0.0 is not even in the list…)

I am totally lost on this one, and any help would be greatly appreciated. I tried working through this all weekend, but to no avail, and I can’t seem to find anything online about it that helps…

Cheers!

Probably the version of ruby 2.0.0 is that of the operating system, surely you installed it, if so you can uninstall it and always use the rvm to work with the ruby versions. I have worked for many years with redmine (creating plugins, customizing, etc.), if you have any questions you can ask me, my emails are [email protected]

You need to install the current version of Ruby.

First of all, Linux will not support any corrupted file or applications. Another thing is if the installed ruby version is 2.0.0 then it will not support the latest version apps. know about the latest version of ruby from Facebook or any other websites. Install the latest version of ruby. Probably it will solve the problem.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs