Error in jruby script


#1

I am trying to backport some script changes that were needed to get
jruby to run in i5/OS AIX runtime (called PASE). The jruby script I
started with was from 1.1RC2 and it does work in 1.1.5 except I am
getting an error when I run rails and I want to make sure that running
the jruby script from 1.1RC2 isn’t the cause.

(FWIW the rails error is an error when running “rails -d mysql library”
to create a new rails project. I get the following:
rails -d mysql
library
/usr/local/jruby-1.1.5/lib/ruby/site_ruby/1.8/rubygems.rb:723:in
set_paths': undefined methoduid’ for nil:NilClass (NoMethodError) )

Anyway, the jruby script error is the following:

/usr/local/jruby-1.1.5/bin/jruby: 001-0002 Arithmetic expression is
not valid

I encounter the error whenever jruby is invoked. Unfortunately, it
isn’t giving me the line number of the error but it appears to occur
right after the “break” statement on or around statement 211 which I can
see when I run the script in verbose mode.

The text in the line above the break is:

Abort processing on first non-opt arg

I am neither a shell script expert nor a jruby expert. The original
script was modified by someone from IBM. I could attempt to contact him
again but wanted to post here first to see if something obvious jumps
out. If I knew where to look for the “Arithmetic expression” I could
probably figure it out, but without a line number, I am stumped.

You can find the script, converted to HTML, here:
http://www.petesworkshop.com/jruby-script-issue.html

Thanks,

Pete


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

#2

I fixed the script problem. The hacks were needed because i5/OS AIX
PASE didn’t support bash but I found binaries for bash that would run
the script out of the box so that one is taken care of. Will re-post
rubygems issue.

Pete

Pete H. wrote:

/usr/local/jruby-1.1.5/lib/ruby/site_ruby/1.8/rubygems.rb:723:in
right after the “break” statement on or around statement 211 which I
could probably figure it out, but without a line number, I am stumped.

To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

#3

Pete H. wrote:

I fixed the script problem. The hacks were needed because i5/OS AIX
PASE didn’t support bash but I found binaries for bash that would run
the script out of the box so that one is taken care of. Will re-post
rubygems issue.

FWIW, we’d love to have bourne shell versions of our startup scripts,
because the bash issues have been reported numerous times. But none of
us are scripting experts, and there’s a lot of bash-magic in what we
have right now.

  • Charlie

To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email