Error in executing the scaffold

Good night.

I am starting in linux and development in Ruby.
I have not much expertise in this area.
I’m using ruby + rails + postgres + RadRails.

I generated a CRUD for testing as follows below:
scaffold Teste nome:string login:string senha:string

When I run this application showing the following error:

NameError in Testes#index

Showing app/views/testes/index.html.erb where line #24 raised:

undefined local variable or method `new_teste_path’ for
#ActionView::Base:0xb6f93560

Extracted source (around line #24):

21:
22:

23:
24: <%= link_to ‘New teste’, new_teste_path %>

RAILS_ROOT: /home/adriano/Aptana Studio Workspace/teste
Application Trace | Framework Trace | Full Trace

app/views/testes/index.html.erb:24
app/controllers/testes_controller.rb:7:in index' -e:2:inload’
-e:2

Please help me solve this problem.

Thanks …

Best Regards
Adriano Dias da Silva

Did you run ‘rake db:migrate’ after you created the new scaffold?
Also, if you did not do it yet, you will also have to run ‘rake
db:create’ to create the db before you run the migration.

On 7/4/10, Adriano Dias da Silva [email protected] wrote:

22:

To post to this group, send email to [email protected]
To unsubscribe from this group, send email to
[email protected]
For more options, visit this group at
http://groups.google.com/group/rubyonrails-talk?hl=en.


Sent from my mobile device

Thank you…

The error was happening only when I created the scaffold/migrate for
RadRails.
So I created the first scaffold/migrate through the terminal and the
other by RadRails and it worked.

Best Regards…
Adriano Dias da Silva

Resolved…