Error during gem install with 1.1

I get this error when I try to install a gem:

jruby -J-Xmx512M -S gem install mocha
JRuby limited openssl loaded. gem install jruby-openssl for full
support.
http://wiki.jruby.org/wiki/JRuby_Builtin_OpenSSL
Bulk updating Gem source index for: http://gems.rubyforge.org
ERROR: While executing gem … (Gem::RemoteSourceException)
Error fetching remote gem cache: ParserException while scanning a
block
mapping we had this expected , but found
org.jvyamlb.tokens.ScalarToken

I did dig up unresolved reports of this error on earlier versions of
JRuby,
but I am using JRuby 1.1

Thanks in advance for any help.


View this message in context:
http://www.nabble.com/Error-during-gem-install-with-1.1-tp20958365p20958365.html
Sent from the JRuby - User mailing list archive at Nabble.com.


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

bemmi wrote:

I did dig up unresolved reports of this error on earlier versions of JRuby,
but I am using JRuby 1.1

Like, 1.1.nothing or 1.1.4/5/6?

  • Charlie

To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

1.1 nothing

jruby -v
ruby 1.8.6 (2008-03-28 rev 6360) [x86-jruby1.1]

Thanks,

Barbara

Charles Oliver N.-2 wrote:

block


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email


View this message in context:
http://www.nabble.com/Error-during-gem-install-with-1.1-tp20958365p20958660.html
Sent from the JRuby - User mailing list archive at Nabble.com.


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

p.s. I also get the same error when I download the gem file and attempt
a
local install

View this message in context:
http://www.nabble.com/Error-during-gem-install-with-1.1-tp20958365p20958779.html
Sent from the JRuby - User mailing list archive at Nabble.com.


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

1.1 is almost a year old. We have fixed many issues since then. I
recommend updating to 1.1.5 or waiting a week until we finalize 1.1.6.

I also just tried a mocha install and it worked fine (on our current
release).

-Tom

On Thu, Dec 11, 2008 at 5:21 PM, bemmi [email protected] wrote:

http://xircles.codehaus.org/manage_email


Blog: http://www.bloglines.com/blog/ThomasEEnebo
Email: [email protected] , [email protected]


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs