Error Deploying 2.3.4 to Tomcat 6, due to Rack 1.0

I’m exploring java deploy. I included every used gems into .war but i
always got this error. Does anyone know how to solve and let me to save
a little time?

GRAVE: Exception caught
C:/Program Files/Apache Software Foundation/Tomcat
6.0/webapps/JBCode/WEB-INF/gems/gems/actionpack-2.3.4/lib/action_controller/middleware_stack.rb:116:in
each': undefined methodnew’ for “Rack::Lock”:String (NoMethodError)
from C:/Program Files/Apache Software Foundation/Tomcat
6.0/webapps/JBCode/WEB-INF/gems/gems/actionpack-2.3.4/lib/action_controller/middleware_stack.rb:116:in
inject' from C:/Program Files/Apache Software Foundation/Tomcat 6.0/webapps/JBCode/WEB-INF/gems/gems/actionpack-2.3.4/lib/action_controller/middleware_stack.rb:116:inbuild’
from C:/Program Files/Apache Software Foundation/Tomcat
6.0/webapps/JBCode/WEB-INF/gems/gems/actionpack-2.3.4/lib/action_controller/dispatcher.rb:130:in
build_middleware_stack' from C:/Program Files/Apache Software Foundation/Tomcat 6.0/webapps/JBCode/WEB-INF/gems/gems/actionpack-2.3.4/lib/action_controller/dispatcher.rb:113:incall’
from C:/Program Files/Apache Software Foundation/Tomcat
6.0/webapps/JBCode/WEB-INF/gems/gems/actionpack-2.3.4/lib/action_controller/reloader.rb:34:in
run' from C:/Program Files/Apache Software Foundation/Tomcat 6.0/webapps/JBCode/WEB-INF/gems/gems/actionpack-2.3.4/lib/action_controller/dispatcher.rb:108:incall’
from file:/C:/Program Files/Apache Software Foundation/Tomcat
6.0/webapps/JBCode/WEB-INF/lib/jruby-rack-0.9.4.jar!/rack/adapter/rails.rb:35:in
serve_rails' from file:/C:/Program Files/Apache Software Foundation/Tomcat 6.0/webapps/JBCode/WEB-INF/lib/jruby-rack-0.9.4.jar!/rack/adapter/rails.rb:40:incall’
from file:/C:/Program Files/Apache Software Foundation/Tomcat
6.0/webapps/JBCode/WEB-INF/lib/jruby-rack-0.9.4.jar!/jruby/rack/rails.rb:144:in
call' from file:/C:/Program Files/Apache Software Foundation/Tomcat 6.0/webapps/JBCode/WEB-INF/lib/jruby-rack-0.9.4.jar!/rack/handler/servlet.rb:17:incall’
from :1
…internal jruby stack elided…
from ActionController::MiddlewareStack.build(C:/Program Files/Apache
Software Foundation/Tomcat
6.0/webapps/JBCode/WEB-INF/gems/gems/actionpack-2.3.4/lib/action_controller/middleware_stack.rb:116)
from Array.each(C:/Program Files/Apache Software Foundation/Tomcat
6.0/webapps/JBCode/WEB-INF/gems/gems/actionpack-2.3.4/lib/action_controller/middleware_stack.rb:116)
from Enumerable.inject(C:/Program Files/Apache Software
Foundation/Tomcat
6.0/webapps/JBCode/WEB-INF/gems/gems/actionpack-2.3.4/lib/action_controller/middleware_stack.rb:116)
from ActionController::MiddlewareStack.build(C:/Program Files/Apache
Software Foundation/Tomcat
6.0/webapps/JBCode/WEB-INF/gems/gems/actionpack-2.3.4/lib/action_controller/dispatcher.rb:130)
from ActionController::Dispatcher.build_middleware_stack(C:/Program
Files/Apache Software Foundation/Tomcat
6.0/webapps/JBCode/WEB-INF/gems/gems/actionpack-2.3.4/lib/action_controller/dispatcher.rb:113)
from ActionController::Dispatcher.call(C:/Program Files/Apache
Software Foundation/Tomcat
6.0/webapps/JBCode/WEB-INF/gems/gems/actionpack-2.3.4/lib/action_controller/reloader.rb:34)
from #Class:01x788315.run(C:/Program Files/Apache Software
Foundation/Tomcat
6.0/webapps/JBCode/WEB-INF/gems/gems/actionpack-2.3.4/lib/action_controller/dispatcher.rb:108)
from ActionController::Dispatcher.call(file:/C:/Program Files/Apache
Software Foundation/Tomcat
6.0/webapps/JBCode/WEB-INF/lib/jruby-rack-0.9.4.jar!/rack/adapter/rails.rb:35)
from Rack::Adapter::Rails.serve_rails(file:/C:/Program Files/Apache
Software Foundation/Tomcat
6.0/webapps/JBCode/WEB-INF/lib/jruby-rack-0.9.4.jar!/rack/adapter/rails.rb:40)
from Rack::Adapter::Rails.call(file:/C:/Program Files/Apache Software
Foundation/Tomcat
6.0/webapps/JBCode/WEB-INF/lib/jruby-rack-0.9.4.jar!/jruby/rack/rails.rb:144)
from JRuby::Rack::RailsRequestSetup.call(file:/C:/Program Files/Apache
Software Foundation/Tomcat
6.0/webapps/JBCode/WEB-INF/lib/jruby-rack-0.9.4.jar!/rack/handler/servlet.rb:17)
from Rack::Handler::Servlet.call(:1)
from (unknown).(unknown)(:1)

Can you upgrade to the newest version of Jruby-rack (0.9.5)? IF so
does the problem still exist? I remember reading a post on Nick
Sieger’s blog about some bug in Jruby-Rack and the latest Rails and
that upgrading to 0.9.5 should fix it.

On Thu, Oct 8, 2009 at 9:24 AM, Marco M.
[email protected] wrote:

`inject’
6.0/webapps/JBCode/WEB-INF/gems/gems/actionpack-2.3.4/lib/action_controller/reloader.rb:34:in
from file:/C:/Program Files/Apache Software Foundation/Tomcat
from Array.each(C:/Program Files/Apache Software Foundation/Tomcat
from ActionController::Dispatcher.call(C:/Program Files/Apache
6.0/webapps/JBCode/WEB-INF/lib/jruby-rack-0.9.4.jar!/rack/adapter/rails.rb:40)


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

Yep, that bug was definitely solved in JRuby-Rack 0.95

Thanks! I was using the old warbler gem (0.9.13) which included the old
JRuby-Rack 0.9.4 …updating to the newest i solved. Then i updated also
the warbler to 0.9.14 version which also have the newest jruby jars
(1.3.1) and i’ve remaked the .war.
Another important step was to copy jdbc jars in the app lib, now it
works!
…but only in production mode, in develop mode i get a thread error,
this is the message:

GRAVE: Application Error
C:/Program Files/Apache Software Foundation/Tomcat
6.0/webapps/JBCode/WEB-INF/gems/gems/actionpack-2.3.4/lib/action_controller/reloader.rb:31:in
lock': Mutex relocking by same thread (ThreadError) from C:/Program Files/Apache Software Foundation/Tomcat 6.0/webapps/JBCode/WEB-INF/gems/gems/actionpack-2.3.4/lib/action_controller/reloader.rb:31:inrun’
from C:/Program Files/Apache Software Foundation/Tomcat
6.0/webapps/JBCode/WEB-INF/gems/gems/actionpack-2.3.4/lib/action_controller/dispatcher.rb:108:in
call' from file:/C:/Program Files/Apache Software Foundation/Tomcat 6.0/webapps/JBCode/WEB-INF/lib/jruby-rack-0.9.5.jar!/rack/adapter/rails.rb:35:inserve_rails’
from file:/C:/Program Files/Apache Software Foundation/Tomcat
6.0/webapps/JBCode/WEB-INF/lib/jruby-rack-0.9.5.jar!/rack/adapter/rails.rb:40:in
call' from file:/C:/Program Files/Apache Software Foundation/Tomcat 6.0/webapps/JBCode/WEB-INF/lib/jruby-rack-0.9.5.jar!/jruby/rack/rails.rb:148:incall’
from file:/C:/Program Files/Apache Software Foundation/Tomcat
6.0/webapps/JBCode/WEB-INF/lib/jruby-rack-0.9.5.jar!/rack/handler/servlet.rb:18:in
`call’
from :1
…internal jruby stack elided…

as if every thread remained active, the creation of the new one generate
the error, for example: if the minimum number of threads is 2, the third
raise that error

i’ve found something about it
http://kenai.com/projects/jruby-rack/lists/issues/archive/2009-09/message/2

On Thu, Oct 8, 2009 at 8:25 AM, Marco M.
[email protected] wrote:

…but only in production mode, in develop mode i get a thread error,
this is the message:

GRAVE: Application Error
C:/Program Files/Apache Software Foundation/Tomcat
6.0/webapps/JBCode/WEB-INF/gems/gems/actionpack-2.3.4/lib/action_controller/reloader.rb:31:in
`lock’: Mutex relocking by same thread (ThreadError)

Build the latest jruby-rack (0.9.6) from git.


Hassan S. ------------------------ [email protected]
twitter: @hassan


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

On Thu, Oct 8, 2009 at 10:50 AM, Hassan S.
[email protected] wrote:

Build the latest jruby-rack (0.9.6) from git.
I’ve also pushed a 0.9.6 snapshot to 1 so that others won’t have to
build it.

/Nick


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

Hassan S. wrote:

Build the latest jruby-rack (0.9.6) from git.

Ok, it has been solved, thank you

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs