Error Bundler

Any body can help me!

i try create a new project, at the end i had message
error bundler.

[email protected]:/home/xxx# rails new depot_b
create
create README.rdoc
create Rakefile
create config.ru
create .gitignore
create Gemfile
create app
create app/assets/images/rails.png
create app/assets/javascripts/application.js
create app/assets/stylesheets/application.css
create app/controllers/application_controller.rb
create app/helpers/application_helper.rb
create app/mailers
create app/models
create app/views/layouts/application.html.erb
create app/mailers/.gitkeep
create app/models/.gitkeep
create config
create config/routes.rb
create config/application.rb
create config/environment.rb
create config/environments
create config/environments/development.rb
create config/environments/production.rb
create config/environments/test.rb
create config/initializers
create config/initializers/backtrace_silencers.rb
create config/initializers/inflections.rb
create config/initializers/mime_types.rb
create config/initializers/secret_token.rb
create config/initializers/session_store.rb
create config/initializers/wrap_parameters.rb
create config/locales
create config/locales/en.yml
create config/boot.rb
create config/database.yml
create db
create db/seeds.rb
create doc
create doc/README_FOR_APP
create lib
create lib/tasks
create lib/tasks/.gitkeep
create lib/assets
create lib/assets/.gitkeep
create log
create log/.gitkeep
create public
create public/404.html
create public/422.html
create public/500.html
create public/favicon.ico
create public/index.html
create public/robots.txt
create script
create script/rails
create test/fixtures
create test/fixtures/.gitkeep
create test/functional
create test/functional/.gitkeep
create test/integration
create test/integration/.gitkeep
create test/unit
create test/unit/.gitkeep
create test/performance/browsing_test.rb
create test/test_helper.rb
create tmp/cache
create tmp/cache/assets
create vendor/assets/javascripts
create vendor/assets/javascripts/.gitkeep
create vendor/assets/stylesheets
create vendor/assets/stylesheets/.gitkeep
create vendor/plugins
create vendor/plugins/.gitkeep
run bundle install
/usr/local/rvm/rubies/ruby-1.9.3-p194/lib/ruby/1.9.1/net/http.rb:2632:in
error!': 400 "Bad request" (Net::HTTPServerException) from /usr/local/rvm/rubies/ruby-1.9.3-p194/lib/ruby/1.9.1/net/http.rb:2641:invalue’
from
/usr/local/rvm/rubies/ruby-1.9.3-p194/lib/ruby/1.9.1/net/http.rb:795:in
connect' from /usr/local/rvm/rubies/ruby-1.9.3-p194/lib/ruby/1.9.1/net/http.rb:755:indo_start’
from
/usr/local/rvm/rubies/ruby-1.9.3-p194/lib/ruby/1.9.1/net/http.rb:750:in
start' from /usr/local/rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/remote_fetcher.rb:329:inconnection_for’
from
/usr/local/rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/remote_fetcher.rb:413:in
request' from /usr/local/rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/remote_fetcher.rb:205:infetch_http’
from
/usr/local/rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/remote_fetcher.rb:238:in
fetch_path' from /usr/local/rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/spec_fetcher.rb:269:inload_specs’
from
/usr/local/rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/spec_fetcher.rb:231:in
block in list' from /usr/local/rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/spec_fetcher.rb:227:ineach’
from
/usr/local/rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/spec_fetcher.rb:227:in
list' from /usr/local/rvm/gems/[email protected]/gems/bundler-1.1.5/lib/bundler/fetcher.rb:212:infetch_all_remote_specs’
from
/usr/local/rvm/gems/[email protected]/gems/bundler-1.1.5/lib/bundler/fetcher.rb:86:in
rescue in specs' from /usr/local/rvm/gems/[email protected]/gems/bundler-1.1.5/lib/bundler/fetcher.rb:69:inspecs’
from
/usr/local/rvm/gems/[email protected]/gems/bundler-1.1.5/lib/bundler/source.rb:234:in
block in remote_specs' from /usr/local/rvm/gems/[email protected]/gems/bundler-1.1.5/lib/bundler/source.rb:232:ineach’
from
/usr/local/rvm/gems/[email protected]/gems/bundler-1.1.5/lib/bundler/source.rb:232:in
remote_specs' from /usr/local/rvm/gems/[email protected]/gems/bundler-1.1.5/lib/bundler/source.rb:165:infetch_specs’
from
/usr/local/rvm/gems/[email protected]/gems/bundler-1.1.5/lib/bundler/source.rb:70:in
specs' from /usr/local/rvm/gems/[email protected]/gems/bundler-1.1.5/lib/bundler/definition.rb:205:inblock (2 levels) in index’
from
/usr/local/rvm/gems/[email protected]/gems/bundler-1.1.5/lib/bundler/definition.rb:202:in
each' from /usr/local/rvm/gems/[email protected]/gems/bundler-1.1.5/lib/bundler/definition.rb:202:inblock in index’
from
/usr/local/rvm/gems/[email protected]/gems/bundler-1.1.5/lib/bundler/index.rb:9:in
build' from /usr/local/rvm/gems/[email protected]/gems/bundler-1.1.5/lib/bundler/definition.rb:198:inindex’
from
/usr/local/rvm/gems/[email protected]/gems/bundler-1.1.5/lib/bundler/definition.rb:192:in
resolve' from /usr/local/rvm/gems/[email protected]/gems/bundler-1.1.5/lib/bundler/definition.rb:127:inspecs’
from
/usr/local/rvm/gems/[email protected]/gems/bundler-1.1.5/lib/bundler/definition.rb:122:in
resolve_remotely!' from /usr/local/rvm/gems/[email protected]/gems/bundler-1.1.5/lib/bundler/installer.rb:48:inrun’
from
/usr/local/rvm/gems/[email protected]/gems/bundler-1.1.5/lib/bundler/installer.rb:12:in
install' from /usr/local/rvm/gems/[email protected]/gems/bundler-1.1.5/lib/bundler/cli.rb:220:ininstall’
from
/usr/local/rvm/gems/[email protected]/gems/bundler-1.1.5/lib/bundler/vendor/thor/task.rb:22:in
run' from /usr/local/rvm/gems/[email protected]/gems/bundler-1.1.5/lib/bundler/vendor/thor/invocation.rb:118:ininvoke_task’
from
/usr/local/rvm/gems/[email protected]/gems/bundler-1.1.5/lib/bundler/vendor/thor.rb:263:in
dispatch' from /usr/local/rvm/gems/[email protected]/gems/bundler-1.1.5/lib/bundler/vendor/thor/base.rb:386:instart’
from
/usr/local/rvm/gems/[email protected]/gems/bundler-1.1.5/bin/bundle:13:in
`’
Fetching gem metadata from https://rubygems.org/.
Error Bundler::HTTPError during request to dependency API
Fetching full source index from https://rubygems.org/
Unfortunately, a fatal error has occurred. Please see the Bundler
troubleshooting documentation at http://bit.ly/bundler-issues. Thanks!

On Aug 8, 2012, at 11:17 AM, fitri sulianto wrote:

 create  .gitignore
 create  app/mailers/.gitkeep
 create  config/initializers/backtrace_silencers.rb
 create  db/seeds.rb
 create  public/404.html
 create  test/functional/.gitkeep
 create  vendor/assets/stylesheets

/usr/local/rvm/rubies/ruby-1.9.3-p194/lib/ruby/1.9.1/net/http.rb:795:in
from
`load_specs’

/usr/local/rvm/gems/[email protected]/gems/bundler-1.1.5/lib/bundler/fetcher.rb:212:in

from
`specs’

/usr/local/rvm/gems/[email protected]/gems/bundler-1.1.5/lib/bundler/index.rb:9:in

from
`install’

/usr/local/rvm/gems/[email protected]/gems/bundler-1.1.5/lib/bundler/vendor/thor/base.rb:386:in


Is there anything flaky about your network connection? This error is
coming when bundler is trying to download a file to install a new gem.
It could be you, or it could be the server on the other end, too.

Walter

On 8 August 2012 16:37, Walter Lee D. [email protected] wrote:

 create  README.rdoc
 create  app/mailers
 create  config/environments/production.rb
 create  config/boot.rb
 create  log
 create  test/fixtures
 create  tmp/cache/assets

/usr/local/rvm/rubies/ruby-1.9.3-p194/lib/ruby/1.9.1/net/http.rb:2641:in
value' from /usr/local/rvm/rubies/ruby-1.9.3-p194/lib/ruby/1.9.1/net/http.rb:795:inconnect’

Is there anything flaky about your network connection? This error is coming when
bundler is trying to download a file to install a new gem. It could be you, or it
could be the server on the other end, too.

Fitri: In case you do not know, in order to continue run
bundle install
which is the bit that failed and is the last thing done when creating
a new project. If that now works then all is ok and it was a
temporary issue with access to server. If it still fails then do you
have a proxy between you and the internet?

Colin

Yes i have proxy,

but i can’t set to bypass proxy,

i try :
http_proxy=http://user:[email protected]_proxy:port/

but nothing happen.

any suggest?

Colin L. wrote in post #1071684:

On 8 August 2012 16:37, Walter Lee D. [email protected] wrote:

 create  README.rdoc
 create  app/mailers
 create  config/environments/production.rb
 create  config/boot.rb
 create  log
 create  test/fixtures
 create  tmp/cache/assets

/usr/local/rvm/rubies/ruby-1.9.3-p194/lib/ruby/1.9.1/net/http.rb:2641:in
value' from /usr/local/rvm/rubies/ruby-1.9.3-p194/lib/ruby/1.9.1/net/http.rb:795:inconnect’

Is there anything flaky about your network connection? This error is coming
when
bundler is trying to download a file to install a new gem. It could be
you, or it
could be the server on the other end, too.

Fitri: In case you do not know, in order to continue run
bundle install
which is the bit that failed and is the last thing done when creating
a new project. If that now works then all is ok and it was a
temporary issue with access to server. If it still fails then do you
have a proxy between you and the internet?

Colin

Yes i have proxy,

buat i try to add this :

http_proxy=http://user:[email protected]_proxy:port/

buat nothing happen…

Any advice?

Walter D. wrote in post #1071682:

On Aug 8, 2012, at 11:17 AM, fitri sulianto wrote:

 create  .gitignore
 create  app/mailers/.gitkeep
 create  config/initializers/backtrace_silencers.rb
 create  db/seeds.rb
 create  public/404.html
 create  test/functional/.gitkeep
 create  vendor/assets/stylesheets

/usr/local/rvm/rubies/ruby-1.9.3-p194/lib/ruby/1.9.1/net/http.rb:795:in
from
`load_specs’

/usr/local/rvm/gems/[email protected]/gems/bundler-1.1.5/lib/bundler/fetcher.rb:212:in

from
`specs’

/usr/local/rvm/gems/[email protected]/gems/bundler-1.1.5/lib/bundler/index.rb:9:in

from
`install’

/usr/local/rvm/gems/[email protected]/gems/bundler-1.1.5/lib/bundler/vendor/thor/base.rb:386:in


Is there anything flaky about your network connection? This error is
coming when bundler is trying to download a file to install a new gem.
It could be you, or it could be the server on the other end, too.

Walter

On 9 August 2012 05:03, fitri sulianto [email protected] wrote:

Yes i have proxy,

buat i try to add this :

http_proxy=http://user:[email protected]_proxy:port/

Added it to what?
Silly question I know but presumably you used the correct user, pwd,
proxy and port?
I have never had to use a proxy but I see that googling for
bundler proxy
provides loads of hits that might be helpful.

Colin