Error 500


#1

Buenas, he migrado mi aplicacion de localhost, a mi servidor
Dreamhost pero justo cuando entro en una vista me sale este error.

{*\generator Msftedit 5.41.15.1507;}\viewkind4\uc1\pard\f0\fs20
Processing TestController#ModoPregMenu (for 62.43.197.69 at 2007-06-10
10:58:36) [GET]\par
Session ID: 996cbebcfdf2e71641005b8ab4ef799e\par
Parameters: {“action”=>“ModoPregMenu”, “id”=>“2”,
“controller”=>“alumno/test”}\par
\par
\par

NoMethodError (undefined method new' for Test:Module):\par /app/controllers/alumno/test_controller.rb:572:inModoPregMenu’\par
/usr/lib/ruby/gems/1.8/gems/actionpack-1.13.3/lib/action_controller/base.rb:1095:in
send'\par /usr/lib/ruby/gems/1.8/gems/actionpack-1.13.3/lib/action_controller/base.rb:1095:inperform_action_without_filters’\par
/usr/lib/ruby/gems/1.8/gems/actionpack-1.13.3/lib/action_controller/filters.rb:632:in
call_filter'\par /usr/lib/ruby/gems/1.8/gems/actionpack-1.13.3/lib/action_controller/filters.rb:638:incall_filter’\par
/usr/lib/ruby/gems/1.8/gems/actionpack-1.13.3/lib/action_controller/filters.rb:438:in
call'\par /usr/lib/ruby/gems/1.8/gems/actionpack-1.13.3/lib/action_controller/filters.rb:637:incall_filter’\par
/usr/lib/ruby/gems/1.8/gems/actionpack-1.13.3/lib/action_controller/filters.rb:619:in
perform_action_without_benchmark'\par /usr/lib/ruby/gems/1.8/gems/actionpack-1.13.3/lib/action_controller/benchmarking.rb:66:inperform_action_without_rescue’\par
/usr/lib/ruby/1.8/benchmark.rb:293:in measure'\par /usr/lib/ruby/gems/1.8/gems/actionpack-1.13.3/lib/action_controller/benchmarking.rb:66:inperform_action_without_rescue’\par
/usr/lib/ruby/gems/1.8/gems/actionpack-1.13.3/lib/action_controller/rescue.rb:83:in
perform_action'\par /usr/lib/ruby/gems/1.8/gems/actionpack-1.13.3/lib/action_controller/base.rb:430:insend’\par
/usr/lib/ruby/gems/1.8/gems/actionpack-1.13.3/lib/action_controller/base.rb:430:in
process_without_filters'\par /usr/lib/ruby/gems/1.8/gems/actionpack-1.13.3/lib/action_controller/filters.rb:624:inprocess_without_session_management_support’\par
/usr/lib/ruby/gems/1.8/gems/actionpack-1.13.3/lib/action_controller/session_management.rb:114:in
process'\par /usr/lib/ruby/gems/1.8/gems/actionpack-1.13.3/lib/action_controller/base.rb:330:inprocess’\par
/usr/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/dispatcher.rb:41:in
dispatch'\par /usr/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/fcgi_handler.rb:168:inprocess_request’\par
/usr/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/fcgi_handler.rb:143:in
process_each_request!'\par /usr/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/fcgi_handler.rb:109:inwith_signal_handler’\par
/usr/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/fcgi_handler.rb:142:in
process_each_request!'\par /usr/lib/ruby/1.8/fcgi.rb:600:ineach_cgi’\par
/usr/lib/ruby/1.8/fcgi.rb:597:in each'\par /usr/lib/ruby/1.8/fcgi.rb:597:ineach_cgi’\par
/usr/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/fcgi_handler.rb:141:in
process_each_request!'\par /usr/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/fcgi_handler.rb:55:inprocess!’\par
/usr/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/fcgi_handler.rb:25:in
`process!’\par
dispatch.fcgi:24\par
}

Y aqui pongo el codigo al que creo que hace referencia

573: #creamos la sesion para el test
574: @session[:test] = nil
575: @test = (session[:test] ||= Test.new)
576: @test.inicializar
577: @test.setmodo(1)

No se porque falla, alguna idea ? (En local si que me funciona )

yo creo que es por algo de esto
NoMethodError (undefined method `new’ for Test:Module):\par
pero no entiendo porque no funciona

==============================
Francisco José Blanco Montero

==============================