Erreur lors de la =?iso-8859-1?q?g=E9n=E9ration_du_cache?=

Bonjour,

J’ai une erreur de cache et je n’arrive pas à déterminer ce qui cloche…
Je n’ai qu’un simple caches_page :index dans mon contrôleur (je n’ai pas
spécifié de répertoire donc il est censé écrire le contenu dans RAILS_ROOT)
Est-ce le fait d’être en mode développement qui empêche le cache de
fonctionner ?

ERROR Errno::EINVAL: Invalid argument
C:/ruby/lib/ruby/1.8/webrick/httpresponse.rb:324:in write' C:/ruby/lib/ruby/1.8/webrick/httpresponse.rb:324:in_write_data’
C:/ruby/lib/ruby/1.8/webrick/httpresponse.rb:317:in _send_file' C:/ruby/lib/ruby/1.8/webrick/httpresponse.rb:272:insend_body_io’
C:/ruby/lib/ruby/1.8/webrick/httpresponse.rb:186:in send_body' C:/ruby/lib/ruby/1.8/webrick/httpresponse.rb:104:insend_response’
C:/ruby/lib/ruby/1.8/webrick/httpserver.rb:79:in run' C:/ruby/lib/ruby/1.8/webrick/server.rb:173:instart_thread’
C:/ruby/lib/ruby/1.8/webrick/server.rb:162:in start_thread' C:/ruby/lib/ruby/1.8/webrick/server.rb:95:instart’
C:/ruby/lib/ruby/1.8/webrick/server.rb:92:in start' C:/ruby/lib/ruby/1.8/webrick/server.rb:23:instart’
C:/ruby/lib/ruby/1.8/webrick/server.rb:82:in start' C:/ruby/lib/ruby/gems/1.8/gems/rails-1.1.4/lib/webrick_server.rb:67:indispatch’
C:/ruby/lib/ruby/gems/1.8/gems/rails-1.1.4/lib/commands/servers/webrick.rb:59
C:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
require' C:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:147:inrequire’
C:/ruby/lib/ruby/gems/1.8/gems/rails-1.1.4/lib/commands/server.rb:30
C:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
require' C:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:147:inrequire’
./script/server:3

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs