Erreur à l'installation de rails sur Debia n Etch 64

Bonjour,

J’installe actuellement rails sur un serveur Debian Etch 64 (ovh).

La commande “gem install rails --include-dependencies” me renvoie
l’erreur suivante :

ERROR: While executing gem … (Gem::InstallError)
gzip error
installing /usr/local/lib/ruby/gems/1.8/cache/rake-0.7.3.gem

J’ai déjà installé avec succés plusieurs serveur Debian Etch (ovh) mai
en 32 bits. Y aurait-il un problème avec les versions 64 bits ? Problème
zlib ?

Pour info, j’ai installé le packet libzlib-ruby comme à l’habitude.

Une idée ?

Jérémy.

Le mercredi 03 octobre 2007 à 11:28 +0200, Jérémy DIERX a écrit :

J’ai déjà installé avec succés plusieurs serveur Debian Etch (ovh) mai
en 32 bits. Y aurait-il un problème avec les versions 64 bits ?
Problème zlib ?

Pour info, j’ai installé le packet libzlib-ruby comme à l’habitude.

Une idée ?

Jérémy.

Bon j’ai trouvé la solution, il faut lancer l’installation de
l’extention zlib de ruby directement dans son répertoire (repertoire
source de ruby après décompression de l’archive) :
cd ruby-1.8.6/ext/zlib/
ruby extconf.rb
make
make install

et relancer :
gem install rails --include-dependencies

Ça peut toujours servir…

Jérémy.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs