Erb problems

Hi List,

I just read this mail on the rails mailing list, that might be of
interest
for ferret. I don’t even know if it is true, that ferret is causing the
erb
problems. If it is, then the fix of rmagick might be applicable to
ferret
too…

Cheers, Jan

Caleb wrote:

Sure enough, I did a search and replace for tabs and replaced them with
spaces. Is this a difference in the way Linux and Windows encode/read
tab characters? If it isn’t an encoding issue then this seems like a
ruby bug (since it works in one environment and not the other).

Any chance you’re using RMagick or Ferret? These have been known to
cause Erb problems on Windows - specifically errors in your .rhtml
files claiming that you have invalid characters in your file. I
believe RMagick was just updated to fix this problem, but I don’t know
about Ferret.

On 9/26/06, Jan P. [email protected] wrote:

Hi List,

I just read this mail on the rails mailing list, that might be of interest
for ferret. I don’t even know if it is true, that ferret is causing the erb
problems. If it is, then the fix of rmagick might be applicable to ferret
too…

Cheers, Jan

Thanks Jan,

This is a known problem. The only fix I’m aware of in RMagick is they
released a gem built with Ruby 1.8.4.20 - stable. Ferret is already
built with this version. Details of the problem can be found here:

http://rubyforge.org/tracker/index.php?func=detail&aid=3837&group_id=12&atid=133

Cheers,
Dave

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs