Environment set up on a G4 Mac PowerBook running Tiger 10.4.1


This is my first post, and I have some basic questions regarding
setup of RubyonRails on a G4 Mac PowerBook running tiger 10.4.11. Now
my machine is almost 10 years old, but its all that I have so I am
hoping that I can get it to work. I am unable to upgrade the OS to
Leopard as my system is to old.

Question 1:
I downloaded a source code, moved it to a dir, called packages in /
usr. I ran sudo ./configure, then I ran sudo make, however I get this

make -f enc.mk RUBY="./miniruby -I./lib -I.ext/common -I./- -r./ext/
purelib.rb " MINIRUBY="./miniruby -I./lib -I.ext/common -I./- -r./ext/
purelib.rb " enc
gcc -I. -I.ext/include/powerpc-darwin8.11.0 -I./include -I. -
DONIG_ENC_REGISTER=rb_enc_register -fno-common -O3 -ggdb -Wextra -Wno-
unused-parameter -Wno-parentheses -Wpointer-arith -Wwrite-strings -
Wno-missing-field-initializers -Wshorten-64-to-32 -Wno-long-long -
pipe -o enc/encdb.o -c ./enc/encdb.c
gcc -dynamic -bundle -o .ext/powerpc-darwin8.11.0/enc/encdb.bundle
enc/encdb.o -L. -L. -L. -Wl,-undefined,dynamic_lookup -Wl,-
multiply_defined,suppress -Wl,-flat_namespace -lpthread -ldl -lobjc
/usr/libexec/gcc/powerpc-apple-darwin8/4.0.1/ld: flag: -undefined
dynamic_lookup can’t be used with MACOSX_DEPLOYMENT_TARGET
environment variable set to: 10.1
collect2: ld returned 1 exit status
make[1]: *** [.ext/powerpc-darwin8.11.0/enc/encdb.bundle] Error 1
make: *** [enc] Error 2

What do I need to do to fix this problem?

Question 2:
I installed PostgreSQL 9.0.4 all the way to make install without
problems. However mac osx does not come with adduser command so I
added it via Netinfo. Settings to:

passwd *
uid 74
expire 0
home /var/empty
gid 74
shell /usr/local/pgsql/bin/
name postgres
realname PostgreSQL Server
change 0

Should the above work?

Question 3:
The postgresql instruction says to run “su - postgres” however when I
add my password and hit enter it simple says sorry, so I assume I am
using the wrong password. What is it sorry about?

I have successfully installed Apache 2.2.19 from source and got the
It works message from localhost:80

Any help would be much appreciated?