Engine: Active_RBAC not working, missing require


#1

Hi there,

I try to install the active_rbac plugin as described in the manual on
the active_rbac trac site. The installation through the plugin script
was great:

ruby script\plugin discover
ruby script\plugin install engines
ruby script\plugin install active_rbac

I set up the environment.rb in rails\config dir correctly to

Engines.start :active_rbac

But if I try a rake db:migrate:engines --trace
he prompted me an error:

** Invoke db:migrate:engines (first_time)
** Invoke environment (first_time)
** Execute environment
rake aborted!
no such file to load – exceptions
c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in
require__' c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:inrequire’
c:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:147:in
requir e' C:/rails/helferlein2/config/../vendor/plugins/active_rbac/lib/active_rbac/group_mixin.rb:1 c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:inrequire’
c:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:147:in
requir e' C:/rails/helferlein2/config/../vendor/plugins/active_rbac/init_engine.rb:41:instart_engine’
C:/rails/helferlein2/config/…/vendor/plugins/engines/lib/engines.rb:183:in
start_engine' C:/rails/helferlein2/config/../vendor/plugins/engines/lib/engines.rb:132:instart’
C:/rails/helferlein2/config/…/vendor/plugins/engines/lib/engines.rb:131:in
start' C:/rails/helferlein2/config/../config/environment.rb:54 c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:inrequire’
c:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:147:in
requir e' c:/ruby/lib/ruby/gems/1.8/gems/rails-1.1.2/lib/tasks/misc.rake:3 c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:387:inexecute’
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:387:in execute' c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:357:ininvoke’
c:/ruby/lib/ruby/1.8/thread.rb:135:in synchronize' c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:350:ininvoke’
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:364:in
invoke_prerequisites' c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:999:ineach’
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:363:in
invoke_prerequisites' c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:356:ininvoke’
c:/ruby/lib/ruby/1.8/thread.rb:135:in synchronize' c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:350:ininvoke’
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:1906:in run' c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:1906:inrun’
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.1/bin/rake:7
c:/ruby/bin/rake.bat:25

Google doesn’t light the way home, have any of you an idea what’s going
on here? The exceptions.rb is correctly installed.

Any help appreciate,

TIA


#2

Daniel Völkerts schrieb:

Google doesn’t light the way home, have any of you an idea what’s going
on here? The exceptions.rb is correctly installed.

https://activerbac.turingstudio.com/trac/ticket/126 is the trac item of
this bug. Only for the archives.

g,