En problemas con FCGI

Hola a todos!

A alguien le suena este error en el fastcgi.crash.log ?
http://pastie.caboo.se/36687
Ya me tiene loco. Estoy configurando Apache2+FCGI en una Debian3.1.
La configuración de Apache2 esta ok, el módulo de FCGI también se carga
correctamente.
El tema es que no consigo ejecutar el dispatch.fcgi de ninguna manera.
Por web simplemente responde un “Application Error. Rails application
failed to start properly”. Y cuando intento ejecutar el dispatch.fcgi
desde commandline no da absolutamente ninguna salida, y me deja en el
fastcgi.crash.log el error que puse arriba. El resto de logs esta
completamente vacio.
Tengo instalados (via apt) los paquetes: ruby1.8 ruby1.8-dev
libfcgi-ruby1.8 libfcgi-dev y los gems de Rails1.2.1 (+dependencias) y
FastCGI0.8.7.

Por cierto, alguien sabe a ciencia cierta la diferencia entre
libapache2-mod-fastcgi y libapache2-mod-fcgid? (además de que uno es GPL
y el otro no?) Lei que el rendimiento es un poco mejor utilizando fcgid,
pero nada concluyente.

Saludos y gracias de antemano.
Mauro.

Mauro P. [w3revolt.com]
escribió:> desde commandline no da absolutamente ninguna salida, y me deja en el

Saludos y gracias de antemano.
Mauro.


Ror-es mailing list
[email protected]
http://lists.simplelogica.net/mailman/listinfo/ror-es

Suponiendo que está todo bien prueba lo que dicen aquí(Comentario de
Nathan Colgate):

http://beast.caboo.se/forums/1/topics/571

No he encontrado mucho más.

Ahora te pregunto, ¿por qué no instalas por comodidad apache 2.2 con
mod_proxy y todo el tinglado?


Rafael Garcia Ortega

Mauro P. [w3revolt.com]
escribió:> desde commandline no da absolutamente ninguna salida, y me deja en el

Saludos y gracias de antemano.
Mauro.


Ror-es mailing list
[email protected]
http://lists.simplelogica.net/mailman/listinfo/ror-es

Otra vez yo, ¿el fichero public/.htaccess lo has modificado?
Has descomentado/insertado la línea:

RewriteRule ^(.*)$ dispatch.fcgi [QSA,L]

Saludos!

PS: Era solo por asegurarme


Rafael Garcia Ortega

Rafael G. wrote:

failed to start properly". Y cuando intento ejecutar el dispatch.fcgi
pero nada concluyente.
Otra vez yo, ¿el fichero public/.htaccess lo has modificado?
Has descomentado/insertado la línea:

RewriteRule ^(.*)$ dispatch.fcgi [QSA,L]

Saludos!

PS: Era solo por asegurarme

Si, el post que me pasas lo había leido, pero nada. Y el .htaccess
también lo tengo cambiado a fcgi.
Lo que me tiene más desconcertado es que ejecutando el dispatch.fcgi por
commandline no me de absolutamente ninguna salida, solo el log.

Los más familiarizados con Debian (3.1 en este caso) saben si para
funcionar con FCGI’s hace falta algún paquete más de los mencione arriba
del todo del hilo?

Mauro.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs