Empty string in response with method defined by means of add


#1

Hi,

I’m using a java web service with a ruby client. The easiest thing to
get me up & running quickly was to define the method by means of
add_method. Hence, I’m not using WSDL.

Sometimes I get a response where a parameter (formally described in
WSDL as type=“soapenc:string”) has attribute nil=true. In other
occasions it’s empty.

The former is recognized by SOAP4R, telling me that the value is nil.
But the latter gives me a SOAP::Mapping::Object with @__soap_value={}
and @soap_value_type={}.

I don’t know really what to do with this value. How can I either get an
empty string or understanand that the resulting object is really empty?

Thanks
AA


#2

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hi,

Sorry for late reply.

aa wrote:

Sometimes I get a response where a parameter (formally described in
WSDL as type=“soapenc:string”) has attribute nil=true. In other
occasions it’s empty.

The former is recognized by SOAP4R, telling me that the value is nil.
But the latter gives me a SOAP::Mapping::Object with @__soap_value={}
and @soap_value_type={}.

I don’t know really what to do with this value. How can I either get an
empty string or understanand that the resulting object is really empty?

Definitely it’s a bug of soap4r… cf.
http://dev.ctor.org/soap4r/ticket/189 . I’ll try to solve this soon.

Regards,
// NaHi
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (Cygwin)

iD8DBQFD5fhKf6b33ts2dPkRAp8MAJ9RwhOyFi9NB9dZVUFpy/rc8Gw84QCgg1g3
oJWuqYiN7B7TeajlfNmRam0=
=ayGg
-----END PGP SIGNATURE-----