Either gem or rails is borked. Still

$ gem install --rdoc --ri --verbose rails
Latest index not found, using quick index
ERROR: Falling back to bulk fetch: No quick index found:
Gem::RemoteFetcher::FetchError: bad response Not Found 404 reading
http://gems.rubyonrails.org/quick/index.rz
Bulk updating Gem source index for: http://gems.rubyonrails.org/
ERROR: Unable to fetch Marshal.4.8.Z: Gem::RemoteFetcher::FetchError:
bad response Not Found 404 reading
http://gems.rubyonrails.org/Marshal.4.8.Z
ERROR: Unable to fetch Marshal.4.8: Gem::RemoteFetcher::FetchError: bad
response Not Found 404 reading http://gems.rubyonrails.org/Marshal.4.8
connection reset after 2 requests, retrying
Missing metadata for 13058 gems
Bulk updating Gem source index for: http://gems.rubyforge.org/
ERROR: Falling back to bulk fetch: No quick index found: Errno::EPIPE:
Broken pipe reading http://gems.rubyonrails.org/quick/index.rz
Bulk updating Gem source index for: http://gems.rubyonrails.org/
ERROR: Unable to fetch Marshal.4.8.Z: Errno::EPIPE: Broken pipe reading
http://gems.rubyonrails.org/Marshal.4.8.Z
ERROR: Unable to fetch Marshal.4.8: Errno::EPIPE: Broken pipe reading
http://gems.rubyonrails.org/Marshal.4.8
ERROR: Unable to fetch yaml.Z: Errno::EPIPE: Broken pipe reading
http://gems.rubyonrails.org/yaml.Z
ERROR: Unable to fetch yaml: Errno::EPIPE: Broken pipe reading
http://gems.rubyonrails.org/yaml
ERROR: While executing gem … (Gem::RemoteSourceException)
Error fetching remote gem cache: Errno::EPIPE: Broken pipe reading
http://gems.rubyonrails.org/yaml

This has been going on now for over a month. I’ve noticed other people
reporting the same or similar problems (and some reporting this with
gems in general, not just rails – thankfully I can still access the
non-rails gems it seems).

Where is the best place to report this to get someone to look at it?

Maybe file a bug report on rubygems’ tracker.

Where is the best place to report this to get someone to look at it?