Edge Rails (1.1.0 RC1) and Typo Trunk


#1

I tried the current Typo trunk with Edge Rails (1.1.0 RC1) and ran
into the following problems:

  1. /public/…/config/environment.rb:107: undefined method
    `enable_upload_progress’ for ActionController::Base:Class
    (NoMethodError). I commented this line out and installed the Upload
    Progress plugin and this problem appears to have gone away.

  2. The second problem I haven’t figured out a work around for yet:

NameError (uninitialized constant Plugins):
/vendor/rails/activerecord/lib///activesupport/lib/
active_support/dependenciesrb:106:in const_missing' /vendor/rails/activerecord/lib///activesupport/lib/ active_support/dependenciesrb:133:inconst_missing’
/components/plugins/textfilters/amazon_controllerrb:1
/vendor/rails/activerecord/lib///activesupport/lib/
active_support/dependenciesrb:142:in load' /vendor/rails/activerecord/lib///activesupport/lib/ active_support/dependenciesrb:142:inload’
/vendor/rails/activerecord/lib///activesupport/lib/
active_support/dependenciesrb:56:in require_or_load' /vendor/rails/activerecord/lib///activesupport/lib/ active_support/dependenciesrb:30:independ_on’
/vendor/rails/activerecord/lib///activesupport/lib/
active_support/dependenciesrb:74:in require_dependency' /vendor/rails/activerecord/lib///activesupport/lib/ active_support/dependenciesrb:74:inrequire_dependency’
/app/controllers/textfilter_controllerrb:113
/app/controllers/textfilter_controllerrb:112:in each' /app/controllers/textfilter_controllerrb:112 /vendor/rails/activerecord/lib///activesupport/lib/ active_support/dependenciesrb:142:inload’
/vendor/rails/activerecord/lib///activesupport/lib/
active_support/dependenciesrb:142:in load' /vendor/rails/activerecord/lib///activesupport/lib/ active_support/dependenciesrb:56:inrequire_or_load’
/vendor/rails/activerecord/lib///activesupport/lib/
active_support/dependenciesrb:30:in depend_on' /vendor/rails/activerecord/lib///activesupport/lib/ active_support/dependenciesrb:74:inrequire_dependency’
/vendor/rails/activerecord/lib///activesupport/lib/
active_support/dependenciesrb:74:in require_dependency' /app/controllers/applicationrb:33 /vendor/rails/activerecord/lib///activesupport/lib/ active_support/dependenciesrb:142:inload’
/vendor/rails/activerecord/lib///activesupport/lib/
active_support/dependenciesrb:142:in load' /vendor/rails/activerecord/lib///activesupport/lib/ active_support/dependenciesrb:56:inrequire_or_load’
/vendor/rails/activerecord/lib///activesupport/lib/
active_support/dependenciesrb:30:in depend_on' /vendor/rails/activerecord/lib///activesupport/lib/ active_support/dependenciesrb:74:inrequire_dependency’
/vendor/rails/activerecord/lib///activesupport/lib/
active_support/dependenciesrb:74:in require_dependency' /vendor/rails/railties/lib/dispatcherrb:69:inprepare_application’
/vendor/rails/railties/lib/dispatcherrb:37:in dispatch' /vendor/rails/railties/lib/fcgi_handlerrb:150:inprocess_request’
/vendor/rails/railties/lib/fcgi_handlerrb:54:in process!' /vendor/rails/railties/lib/fcgi_handlerrb:53:ineach_cgi’
/usr/lib/ruby/gems/18/gems/fcgi-0861//fcgirb:597:in each' /usr/lib/ruby/gems/18/gems/fcgi-0861//fcgirb:597:ineach_cgi’
/vendor/rails/railties/lib/fcgi_handlerrb:53:in process!' /vendor/rails/railties/lib/fcgi_handlerrb:23:inprocess!’
public/dispatchfcgi:24

I posted this on the Typo list as well but haven’t heard back yet.

Any help would be appreciated.

Thanks.
Steven


#2

On Wed, Mar 22, 2006 at 12:25:33AM -0600, Steven S. wrote:

I tried the current Typo trunk with Edge Rails (1.1.0 RC1) and ran
into the following problems:

  1. /public/…/config/environment.rb:107: undefined method
    `enable_upload_progress’ for ActionController::Base:Class
    (NoMethodError). I commented this line out and installed the Upload
    Progress plugin and this problem appears to have gone away.

The upload progress bar (which had been deprecated) was removed. It’s
available as a plugin now.

You can use the plugin script to install it.

marcel


#3

Sorry but I have the same problem with Typo after upgrade to 1.1.
I tried installing the only plugin I could find in
http://wiki.rubyonrails.org/rails/pages/Plugins which was the “Upload
Progress Bar” and it didn’t seem to change much.

Is it some other plugin?
Is it incorrect to use script/plugin install upload_progress
Do I have to do something more?

On 3/22/06, Marcel Molina Jr. removed_email_address@domain.invalid wrote:

available as a plugin now.