Echoe requires RubyGems version >= 1.2


#1

I keep getting this error when attempting to install just about
anything.
I can’t find anything about it via google.

Thanks in advance.


#2

I can’t update my gems to 1.2

I have tried about everything.
gem update --system fails

early in the --debug I get:
“invalid Gem::Specification format [“1.2.0”, 3, “flow”…”

followed by a series of errors
and then it finally says:
nothing to update

I did an update of ruby to no avail
sudo gem update ruby
It did update a lot of stuff, but gem update --system still fails
Gems updated: columnize, linecache, ruby-debug-base, ruby-debug,
columnize, linecache, ruby-debug-base, ruby-debug, ruby-debug-base,
ruby-debug-ide

Eric H.'s page doesn’t mention anything except gem update --system

me => :stuck


#3

OK,
I found it
sudo gem install rubygems-update
then
sudo update_rubygems

This was on Ubuntu Hardy Heron.