Due versioni di rails (2.0.2 - 1.2.3)

ciao
ho due versioni di rails sul mio hosting (bluehost.com) la 2.0.2
installata di default e che non posso disinstallare e la 1.2.3
installata da me per far girare le mie vecchie applicazioni.
Qualcuno sa come fare per far partire la mia app con la vecchia versione
di rails?

ciao e grazie

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Giovanno Z. wrote:

ciao
ho due versioni di rails sul mio hosting (bluehost.com) la 2.0.2
installata di default e che non posso disinstallare e la 1.2.3
installata da me per far girare le mie vecchie applicazioni.
Qualcuno sa come fare per far partire la mia app con la vecchia versione
di rails?

Ciao Giovanni,

hai due opzioni.

La prima è quella di assegnare il valore ‘1.2.3’ alla costante
RAILS_GEM_VERSION all’interno del file config/environment.rb nel tuo
progetto. La riga dovrebbe esistere già ma sotto forma di commento.
Dovrai solamente rimuovere il # che la rende tale.

La seconda opzione è quella di fare il freezing delle gemme. In sostanza
lanciando il task ‘rake rails:freeze:gems’ dalla tua macchina dove la
versione corrente è la 1.2.3, le gemme necessarie per Rails 1.2.3
vengono copiate all’interno della cartella vendor/rails del tuo
progetto. In questo modo, il progetto utilizzerà queste gemme
indipendentemente dalla versione presente sul server.

Ciao,
Antonio


http://antoniocangiano.com - Zen and the Art of Programming
http://stacktrace.it - Aperiodico di resistenza informatica
http://math-blog.com - Math Blog: Mathematics is wonderful!
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.8 (Darwin)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iEYEARECAAYFAkgOQggACgkQqCqsu0qUj9QQkACeI5U/AOpwFQFRIelgWV5ryCrY
dvYAoJ8DMemnTmE9t9D3efi4sLsLFyFo
=cLvD
-----END PGP SIGNATURE-----

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs