Dreamhost and fcgi....help!

I’ve got my app running under cgi, but I keep getting pwned by fcgi.

  • app is installed at www.mydomain.com
  • web root is www.mydomain.com/public (this works w/ regular cgi)
  • /public has correct permissions
  • .htaccess: rewrite rule changed to use .fcgi
  • shebang on dispatch.fcgi and dispatch.rb is set to #!/usr/bin/ruby1.8
    (also tried just ruby)
    -environment.rb : running in prod

Any ideas? o_O

You don’t say that you’ve got execute permissions on dispatch.*… do
you?

Also, I had some issues on DH that could only be fixed by "kill -9"ing
the dispatch.fcgi processes.

Finally, to keep my site stable I had to add one of these to my crontab:

*/10 * * * * /usr/bin/curl http://www.direct-debit.com.au/blah
-o /dev/null --stderr /dev/null

(where /blah is a path that is NOT cached)

HTH,

Dan
www.peoplehub.com.au

That crontab was supposed to be one line, not two…

I also did a 755 on dispatch*…no joy

2006/3/13, Chris S. [email protected]:

I also did a 755 on dispatch*…no joy

I have this issue with DreamHost too. Sometimes I simply have to wait
a while before the app will restart. This is a problem. Wait half an
hour and try again.

Bye !

You’re right. I tried my app today and it’s running fine. That was still
really frustrating…

François Beausoleil wrote:

2006/3/13, Chris S. [email protected]:

I also did a 755 on dispatch*…no joy

I have this issue with DreamHost too. Sometimes I simply have to wait
a while before the app will restart. This is a problem. Wait half an
hour and try again.

Bye !

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs